summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 09:20:37 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:11:13 +0100
commitbed011581e228f5e3fcc55e3a9c9649f98f14716 (patch)
treef3b6c59936953adb521becd19989c2a0488899c9 /x11-misc/xrootconsole
parentx11-misc/grabc: respect PKG_CONFIG (diff)
downloadgentoo-bed011581e228f5e3fcc55e3a9c9649f98f14716.tar.gz
gentoo-bed011581e228f5e3fcc55e3a9c9649f98f14716.tar.bz2
gentoo-bed011581e228f5e3fcc55e3a9c9649f98f14716.zip
x11-misc/xrootconsole: respect PKG_CONFIG
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc/xrootconsole')
-rw-r--r--x11-misc/xrootconsole/files/xrootconsole-0.6.makefile.patch8
-rw-r--r--x11-misc/xrootconsole/xrootconsole-0.6-r1.ebuild8
2 files changed, 9 insertions, 7 deletions
diff --git a/x11-misc/xrootconsole/files/xrootconsole-0.6.makefile.patch b/x11-misc/xrootconsole/files/xrootconsole-0.6.makefile.patch
index 4b3aee406733..e5efe6541e11 100644
--- a/x11-misc/xrootconsole/files/xrootconsole-0.6.makefile.patch
+++ b/x11-misc/xrootconsole/files/xrootconsole-0.6.makefile.patch
@@ -1,5 +1,5 @@
---- a/Makefile.org 2004-02-20 22:53:28.000000000 +0100
-+++ b/Makefile 2010-02-08 12:01:11.000000000 +0100
+--- a/Makefile
++++ b/Makefile
@@ -43,20 +43,16 @@
else echo Bleeding Edge Version; \
fi;)
@@ -12,7 +12,7 @@
- -I /usr/X11R6/include
-LDFLAGS = -s
+CFLAGS += -DNDEBUG -Wall "-DXROOTCONSOLE_VERSION=\"$(VERSION)\"" \
-+ $(shell pkg-config --cflags x11)
++ $(shell ${PKG_CONFIG} --cflags x11)
# for testing
#CFLAGS = -g -Wall "-DXROOTCONSOLE_VERSION=\"$(VERSION) (debug build)\"" \
@@ -20,7 +20,7 @@
#LDFLAGS =
-LIBS = -L/usr/X11R6/lib -lX11 -lutil
-+LIBS = $(shell pkg-config --libs x11) -lutil
++LIBS = $(shell ${PKG_CONFIG} --libs x11) -lutil
OBJS = main.o util.o
diff --git a/x11-misc/xrootconsole/xrootconsole-0.6-r1.ebuild b/x11-misc/xrootconsole/xrootconsole-0.6-r1.ebuild
index 58f43f33c854..9eb3c8efffbc 100644
--- a/x11-misc/xrootconsole/xrootconsole-0.6-r1.ebuild
+++ b/x11-misc/xrootconsole/xrootconsole-0.6-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -18,7 +18,9 @@ RDEPEND="
DEPEND="
${RDEPEND}
- x11-base/xorg-proto"
+ x11-base/xorg-proto
+ virtual/pkgconfig
+"
PATCHES=(
"${FILESDIR}/${P}.noversion.patch"
@@ -29,7 +31,7 @@ PATCHES=(
DOCS=( TODO NEWS CREDITS )
src_compile() {
- tc-export CC
+ tc-export CC PKG_CONFIG
emake
}