summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-07-24 13:53:58 +0200
committerJeroen Roovers <jer@gentoo.org>2016-07-24 13:53:58 +0200
commitf966d5739580b59fcc675a813ed5e2761886e8eb (patch)
tree01df9b7d63722f03c677f86efebefcb7cd4ff387 /x11-misc/xsnow/xsnow-1.42-r2.ebuild
parentx11-drivers/nvidia-drivers: Old. (diff)
downloadgentoo-f966d5739580b59fcc675a813ed5e2761886e8eb.tar.gz
gentoo-f966d5739580b59fcc675a813ed5e2761886e8eb.tar.bz2
gentoo-f966d5739580b59fcc675a813ed5e2761886e8eb.zip
x11-misc/xsnow: EAPI update.
Package-Manager: portage-2.3.0
Diffstat (limited to 'x11-misc/xsnow/xsnow-1.42-r2.ebuild')
-rw-r--r--x11-misc/xsnow/xsnow-1.42-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11-misc/xsnow/xsnow-1.42-r2.ebuild b/x11-misc/xsnow/xsnow-1.42-r2.ebuild
new file mode 100644
index 000000000000..d33751266610
--- /dev/null
+++ b/x11-misc/xsnow/xsnow-1.42-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="let it snow on your desktop and windows"
+HOMEPAGE="http://dropmix.xs4all.nl/rick/Xsnow/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXext
+ x11-libs/libXpm
+"
+DEPEND="
+ ${RDEPEND}
+ app-text/rman
+ x11-misc/imake
+ x11-misc/gccmakedep
+ x11-proto/xextproto
+ x11-proto/xproto
+"
+
+src_compile() {
+ xmkmf || die
+ make depend || die
+ emake \
+ CC="$(tc-getCC)" \
+ CDEBUGFLAGS="${CFLAGS}" \
+ LOCAL_LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin xsnow
+ rman -f HTML < xsnow._man > xsnow.1-html || die
+ newman xsnow._man xsnow.1
+ newdoc xsnow.1-html xsnow.1.html
+ dodoc README
+}