summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-04-10 11:58:26 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-04-10 11:58:26 +0200
commitb078be025685616592237e74ba45810684862371 (patch)
tree65727c8f8befc826db74ff3c3bec3b527503cb16 /x11-misc/xsnow/xsnow-3.3.0.ebuild
parentx11-misc/xsnow: Remove old (diff)
downloadgentoo-b078be025685616592237e74ba45810684862371.tar.gz
gentoo-b078be025685616592237e74ba45810684862371.tar.bz2
gentoo-b078be025685616592237e74ba45810684862371.zip
x11-misc/xsnow: Version bump 3.3.0
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'x11-misc/xsnow/xsnow-3.3.0.ebuild')
-rw-r--r--x11-misc/xsnow/xsnow-3.3.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-misc/xsnow/xsnow-3.3.0.ebuild b/x11-misc/xsnow/xsnow-3.3.0.ebuild
new file mode 100644
index 000000000000..b088c85f4918
--- /dev/null
+++ b/x11-misc/xsnow/xsnow-3.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools xdg
+
+DESCRIPTION="let it snow on your desktop and windows"
+HOMEPAGE="https://janswaal.home.xs4all.nl/Xsnow/ https://sourceforge.net/projects/xsnow/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/libxml2
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libXpm
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0.7-gamesdir.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}