summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-12-21 11:05:41 +0100
committerFlorian Schmaus <flow@gentoo.org>2022-12-21 11:07:02 +0100
commit2558ddaebc75727e79645d718aa3bb7113941e9d (patch)
tree67983a2d15d2f0d2a39380b6f822a79e1a57121a /x11-misc/xsnow/xsnow-3.6.0-r1.ebuild
parentx11-wm/marco: drop 1.24.2 (diff)
downloadgentoo-2558ddaebc75727e79645d718aa3bb7113941e9d.tar.gz
gentoo-2558ddaebc75727e79645d718aa3bb7113941e9d.tar.bz2
gentoo-2558ddaebc75727e79645d718aa3bb7113941e9d.zip
x11-misc/xsnow: install xscreensaver hack
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'x11-misc/xsnow/xsnow-3.6.0-r1.ebuild')
-rw-r--r--x11-misc/xsnow/xsnow-3.6.0-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/x11-misc/xsnow/xsnow-3.6.0-r1.ebuild b/x11-misc/xsnow/xsnow-3.6.0-r1.ebuild
new file mode 100644
index 000000000000..b1390bb2529c
--- /dev/null
+++ b/x11-misc/xsnow/xsnow-3.6.0-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit autotools xdg
+
+DESCRIPTION="let it snow on your desktop and windows"
+HOMEPAGE="https://www.ratrabbit.nl/ratrabbit/xsnow/"
+SRC_URI="https://www.ratrabbit.nl/downloads/xsnow/${P}.tar.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ dev-libs/glib:2
+ sci-libs/gsl:=
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXinerama
+ x11-libs/libXpm
+ x11-libs/libXtst
+ x11-libs/libxkbcommon
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0.7-gamesdir.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ # Install xscreensaver hack, which calls xsnow with the correct
+ # arguments. xscreensaver calls all hacks with --root, however xsnow
+ # only understands -root and will exit with an error if an unknown
+ # argument (--root) is provided.
+ exeinto usr/$(get_libdir)/misc/xscreensaver
+ newexe - xsnow <<-EOF
+ #/usr/bin/env bash
+ exec "${EPREFIX}/usr/bin/xsnow" -nomenu -root
+EOF
+}