summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/xssstate/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/xssstate/files')
-rw-r--r--x11-misc/xssstate/files/xssstate-1.0.20130103-gentoo.patch89
1 files changed, 89 insertions, 0 deletions
diff --git a/x11-misc/xssstate/files/xssstate-1.0.20130103-gentoo.patch b/x11-misc/xssstate/files/xssstate-1.0.20130103-gentoo.patch
new file mode 100644
index 000000000000..b951afe91a88
--- /dev/null
+++ b/x11-misc/xssstate/files/xssstate-1.0.20130103-gentoo.patch
@@ -0,0 +1,89 @@
+--- a/Makefile
++++ b/Makefile
+@@ -5,7 +5,7 @@
+ SRC = xssstate.c
+ OBJ = ${SRC:.c=.o}
+
+-all: options xssstate
++all: xssstate
+
+ options:
+ @echo xssstate build options:
+@@ -14,42 +14,34 @@
+ @echo "CC = ${CC}"
+
+ .c.o:
+- @echo CC $<
+- @${CC} -c ${CFLAGS} $<
++ ${CC} -c ${CFLAGS} $<
+
+ ${OBJ}: config.mk
+
+-xssstate: xssstate.o
+- @echo CC -o $@
+- @${CC} -o $@ xssstate.o ${LDFLAGS}
++xssstate: options xssstate.o
++ ${CC} -o $@ xssstate.o ${LDFLAGS}
+
+ clean:
+- @echo cleaning
+ @rm -f xssstate ${OBJ} xssstate-${VERSION}.tar.gz
+
+ dist: clean
+- @echo creating dist tarball
+- @mkdir -p xssstate-${VERSION}
+- @cp -R LICENSE README Makefile config.mk xsidle.sh \
++ mkdir -p xssstate-${VERSION}
++ cp -R LICENSE README Makefile config.mk xsidle.sh \
+ xssstate.1 arg.h ${SRC} xssstate-${VERSION}
+- @tar -cf xssstate-${VERSION}.tar xssstate-${VERSION}
+- @gzip xssstate-${VERSION}.tar
+- @rm -rf xssstate-${VERSION}
++ tar -cf xssstate-${VERSION}.tar xssstate-${VERSION}
++ gzip xssstate-${VERSION}.tar
++ rm -rf xssstate-${VERSION}
+
+ install: all
+- @echo installing executable file to ${DESTDIR}${PREFIX}/bin
+- @mkdir -p ${DESTDIR}${PREFIX}/bin
+- @cp -f xssstate ${DESTDIR}${PREFIX}/bin
+- @chmod 755 ${DESTDIR}${PREFIX}/bin/xssstate
+- @echo installing manual page to ${DESTDIR}${MANPREFIX}/man1
+- @mkdir -p ${DESTDIR}${MANPREFIX}/man1
+- @sed "s/VERSION/${VERSION}/g" < xssstate.1 > ${DESTDIR}${MANPREFIX}/man1/xssstate.1
+- @chmod 644 ${DESTDIR}${MANPREFIX}/man1/xssstate.1
++ mkdir -p ${DESTDIR}${PREFIX}/bin
++ cp -f xssstate ${DESTDIR}${PREFIX}/bin
++ chmod 755 ${DESTDIR}${PREFIX}/bin/xssstate
++# mkdir -p ${DESTDIR}${MANPREFIX}/man1
++# @sed "s/VERSION/${VERSION}/g" < xssstate.1 > ${DESTDIR}${MANPREFIX}/man1/xssstate.1
++# @chmod 644 ${DESTDIR}${MANPREFIX}/man1/xssstate.1
+
+ uninstall:
+- @echo removing executable file from ${DESTDIR}${PREFIX}/bin
+- @rm -f ${DESTDIR}${PREFIX}/bin/xssstate
+- @echo removing manual page from ${DESTDIR}${MANPREFIX}/man1
+- @rm -f ${DESTDIR}${MANPREFIX}/man1/xssstate.1
++ rm -f ${DESTDIR}${PREFIX}/bin/xssstate
++# @rm -f ${DESTDIR}${MANPREFIX}/man1/xssstate.1
+
+ .PHONY: all options clean dist install uninstall
+--- a/config.mk
++++ b/config.mk
+@@ -13,13 +13,13 @@
+
+ # flags
+ CPPFLAGS = -DVERSION=\"${VERSION}\"
+-CFLAGS = -g -std=c99 -pedantic -Wall -O0 ${INCS} ${CPPFLAGS}
+-LDFLAGS = -g ${LIBS}
++CFLAGS += -std=c99 -pedantic -Wall ${INCS} ${CPPFLAGS}
++LDFLAGS += ${LIBS}
+
+ # Solaris
+ #CFLAGS = -fast ${INCS} -DVERSION=\"${VERSION}\"
+ #LDFLAGS = ${LIBS}
+
+ # compiler and linker
+-CC = cc
++CC ?= cc
+