summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2016-10-10 21:05:42 +0200
committerSebastian Pipping <sping@gentoo.org>2016-10-10 21:05:42 +0200
commitccc7acf73c566ddb96a4e48298cb1587a46988ca (patch)
tree742aa41bb7f5d9230a231217de4c98b5b7a7775c /x11-misc/xvfb-run/xvfb-run-1.18.4_p2.ebuild
parentdev-python/dnspython: bump and combine py2/3 into one ebuild bug 596502 (diff)
downloadgentoo-ccc7acf73c566ddb96a4e48298cb1587a46988ca.tar.gz
gentoo-ccc7acf73c566ddb96a4e48298cb1587a46988ca.tar.bz2
gentoo-ccc7acf73c566ddb96a4e48298cb1587a46988ca.zip
x11-apps/xvfb-run: Move to x11-misc/ (bug #571864)
Package-Manager: portage-2.3.1
Diffstat (limited to 'x11-misc/xvfb-run/xvfb-run-1.18.4_p2.ebuild')
-rw-r--r--x11-misc/xvfb-run/xvfb-run-1.18.4_p2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-misc/xvfb-run/xvfb-run-1.18.4_p2.ebuild b/x11-misc/xvfb-run/xvfb-run-1.18.4_p2.ebuild
new file mode 100644
index 000000000000..f5d932854a5b
--- /dev/null
+++ b/x11-misc/xvfb-run/xvfb-run-1.18.4_p2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+MY_PN=xorg-server
+MY_PV=${PV/_p/-}
+DESCRIPTION="Run a command in a virtual X server environment"
+HOMEPAGE="https://packages.debian.org/sid/xvfb"
+SRC_URI="mirror://debian/pool/main/${MY_PN:0:1}/${MY_PN}/${MY_PN}_${MY_PV}.diff.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-util/patchutils"
+RDEPEND="x11-apps/xauth
+ x11-base/xorg-server[xvfb]"
+
+S="${WORKDIR}"/
+
+src_prepare() {
+ # Not in src_unpack to silence warning "'patch' call should be moved to src_prepare"
+ filterdiff --include='*xvfb-run*' ${MY_PN}_${MY_PV}.diff | patch || die
+}
+
+src_install() {
+ doman ${PN}.1
+ dobin ${PN}
+}