summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/xwit/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/xwit/files')
-rw-r--r--x11-misc/xwit/files/Makefile6
-rw-r--r--x11-misc/xwit/files/malloc.patch11
-rw-r--r--x11-misc/xwit/files/xwit-3.4-malloc-includes.patch49
3 files changed, 66 insertions, 0 deletions
diff --git a/x11-misc/xwit/files/Makefile b/x11-misc/xwit/files/Makefile
new file mode 100644
index 000000000000..7b106f0d7168
--- /dev/null
+++ b/x11-misc/xwit/files/Makefile
@@ -0,0 +1,6 @@
+src = xwit.c dsimple.c ClientWin.c
+
+all: xwit
+
+xwit: $(o)
+ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) $(src) -o xwit -lX11
diff --git a/x11-misc/xwit/files/malloc.patch b/x11-misc/xwit/files/malloc.patch
new file mode 100644
index 000000000000..41c3a7b82eff
--- /dev/null
+++ b/x11-misc/xwit/files/malloc.patch
@@ -0,0 +1,11 @@
+--- dsimple.c_ 2005-06-05 16:07:10.000000000 +0200
++++ dsimple.c 2005-06-05 16:07:47.000000000 +0200
+@@ -46,7 +46,7 @@
+ char *Malloc(size)
+ unsigned size;
+ {
+- char *data, *malloc();
++ char *data; //, *malloc();
+
+ if (!(data = malloc(size)))
+ Fatal_Error("Out of memory!");
diff --git a/x11-misc/xwit/files/xwit-3.4-malloc-includes.patch b/x11-misc/xwit/files/xwit-3.4-malloc-includes.patch
new file mode 100644
index 000000000000..beda933c19f3
--- /dev/null
+++ b/x11-misc/xwit/files/xwit-3.4-malloc-includes.patch
@@ -0,0 +1,49 @@
+--- a/dsimple.c 1995-10-19 00:59:17.000000000 +0100
++++ b/dsimple.c 2013-08-03 18:27:16.670506562 +0200
+@@ -5,6 +5,8 @@
+ #include <X11/Xutil.h>
+ #include <X11/cursorfont.h>
+ #include <stdio.h>
++#include <stdlib.h> /* malloc() */
++#include <unistd.h> /* exit() */
+ /*
+ * Other_stuff.h: Definitions of routines in other_stuff.
+ *
+@@ -46,7 +48,7 @@
+ char *Malloc(size)
+ unsigned size;
+ {
+- char *data, *malloc();
++ char *data; /*, *malloc(); */
+
+ if (!(data = malloc(size)))
+ Fatal_Error("Out of memory!");
+@@ -62,7 +64,7 @@
+ char *ptr;
+ int size;
+ {
+- char *new_ptr, *realloc();
++ char *new_ptr; /*, *realloc(); */
+
+ if (!ptr)
+ return(Malloc(size));
+--- a/xwit.c 1997-10-21 03:32:54.000000000 +0200
++++ b/xwit.c 2013-08-03 18:38:52.075456902 +0200
+@@ -31,6 +31,8 @@
+ #include <X11/Xutil.h>
+ #include <X11/Xproto.h>
+ #include <stdio.h>
++#include <stdlib.h> /* atoi() */
++#include <sys/select.h> /* select() */
+ #include <sys/time.h>
+ #include "dsimple.h"
+
+@@ -134,7 +136,7 @@
+ struct timeval tv;
+ tv.tv_sec = ms/1000;
+ tv.tv_usec = (ms%1000)*1000;
+- select(0,(int*)0,(int*)0,(int*)0,&tv);
++ select(0,0,0,0,&tv);
+ }
+
+ /*