summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-11-30 10:20:50 +0100
committerFlorian Schmaus <flow@gentoo.org>2022-11-30 10:39:35 +0100
commit069a2651e71face888b8de57af7808a04c9095e2 (patch)
tree5ade45b9e8b934b713a1fb3159afcbbe67069579 /x11-misc
parentx11-misc/autorandr: stabilize 1.12.1-r2 for amd64, x86 (diff)
downloadgentoo-069a2651e71face888b8de57af7808a04c9095e2.tar.gz
gentoo-069a2651e71face888b8de57af7808a04c9095e2.tar.bz2
gentoo-069a2651e71face888b8de57af7808a04c9095e2.zip
x11-misc/autorandr: drop 1.12.1
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/autorandr/autorandr-1.12.1.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/x11-misc/autorandr/autorandr-1.12.1.ebuild b/x11-misc/autorandr/autorandr-1.12.1.ebuild
deleted file mode 100644
index 2235547cc76e..000000000000
--- a/x11-misc/autorandr/autorandr-1.12.1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit bash-completion-r1 distutils-r1 systemd udev
-
-if [[ "${PV}" = "9999" ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/phillipberndt/${PN}.git"
-else
- SRC_URI="https://github.com/phillipberndt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 x86"
-fi
-
-DESCRIPTION="Automatically select a display configuration based on connected devices"
-HOMEPAGE="https://github.com/phillipberndt/autorandr"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="launcher udev"
-
-RDEPEND="
- x11-apps/xrandr
- launcher? ( x11-libs/libxcb )
- udev? ( virtual/udev )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-src_compile() {
- distutils-r1_src_compile
-
- if use launcher; then
- emake contrib/autorandr_launcher/autorandr-launcher
- fi
-}
-
-src_install() {
- distutils-r1_src_install
-
- doman autorandr.1
-
- local targets=(
- autostart_config
- bash_completion
- systemd
- $(usev launcher)
- $(usev udev)
- )
-
- emake DESTDIR="${D}" \
- BASH_COMPLETIONS_DIR="$(get_bashcompdir)" \
- SYSTEMD_UNIT_DIR="$(systemd_get_systemunitdir)" \
- UDEV_RULES_DIR="$(get_udevdir)"/rules.d \
- $(printf "install_%s " "${targets[@]}")
-}
-
-pkg_postinst() {
- if use udev; then
- udev_reload
- fi
-}