summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2019-06-21 12:19:38 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2019-06-22 00:05:26 -0400
commit0a32e5ac9d072ec0a3c84c4f0a7f05f85ffd3c51 (patch)
tree1d9677c7f555a4b7faa91a0204058729a36e9c81 /x11-misc
parentx11-libs/libXt: Version bump to 1.2.0 (diff)
downloadgentoo-0a32e5ac9d072ec0a3c84c4f0a7f05f85ffd3c51.tar.gz
gentoo-0a32e5ac9d072ec0a3c84c4f0a7f05f85ffd3c51.tar.bz2
gentoo-0a32e5ac9d072ec0a3c84c4f0a7f05f85ffd3c51.zip
x11-misc/mate-notification-daemon: Fix deps
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: NP-Hardass <NP-Hardass@gentoo.org> Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/mate-notification-daemon/mate-notification-daemon-1.22.0-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/x11-misc/mate-notification-daemon/mate-notification-daemon-1.22.0-r1.ebuild b/x11-misc/mate-notification-daemon/mate-notification-daemon-1.22.0-r1.ebuild
new file mode 100644
index 000000000000..b7b3b1ddb731
--- /dev/null
+++ b/x11-misc/mate-notification-daemon/mate-notification-daemon-1.22.0-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="MATE Notification daemon"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE=""
+
+COMMON_DEPEND="dev-libs/atk
+ >=dev-libs/glib-2.50:2
+ >=sys-apps/dbus-1
+ x11-libs/cairo
+ >=x11-libs/gdk-pixbuf-2.22:2
+ >=x11-libs/libnotify-0.7
+ x11-libs/libX11
+ virtual/libintl
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/libwnck-3:3
+ >=media-libs/libcanberra-0.4:0[gtk3]
+ !x11-misc/notify-osd
+ !x11-misc/qtnotifydaemon
+ !x11-misc/notification-daemon"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ app-arch/xz-utils
+ dev-util/gdbus-codegen
+ >=dev-util/intltool-0.50.1
+ sys-devel/gettext:*
+ >=sys-devel/libtool-2.2.6:2
+ virtual/pkgconfig:*"
+
+src_configure() {
+ mate_src_configure
+}
+
+src_install() {
+ mate_src_install
+
+ insinto /usr/share/dbus-1/services
+ doins "${FILESDIR}/org.freedesktop.Notifications.service"
+}