summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2018-02-26 17:03:38 -0500
committerMike Gilbert <floppym@gentoo.org>2018-02-26 17:03:58 -0500
commit126d7108fb0ba692a4d56abc884fa00f7ace5bf2 (patch)
tree460013efa3cc8c3c76a9e599ad5eddf8f3fec0f2 /x11-misc
parentsys-kernel/ck-sources: genpatches-4.15-7. (diff)
downloadgentoo-126d7108fb0ba692a4d56abc884fa00f7ace5bf2.tar.gz
gentoo-126d7108fb0ba692a4d56abc884fa00f7ace5bf2.tar.bz2
gentoo-126d7108fb0ba692a4d56abc884fa00f7ace5bf2.zip
x11-misc/lightdm: call systemd_reenable
Closes: https://bugs.gentoo.org/645648 Package-Manager: Portage-2.3.24_p18, Repoman-2.3.6_p99
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/lightdm/lightdm-1.18.3-r1.ebuild4
-rw-r--r--x11-misc/lightdm/lightdm-1.24.0-r1.ebuild6
2 files changed, 9 insertions, 1 deletions
diff --git a/x11-misc/lightdm/lightdm-1.18.3-r1.ebuild b/x11-misc/lightdm/lightdm-1.18.3-r1.ebuild
index cd5bfce7b439..0592df3577ea 100644
--- a/x11-misc/lightdm/lightdm-1.18.3-r1.ebuild
+++ b/x11-misc/lightdm/lightdm-1.18.3-r1.ebuild
@@ -127,3 +127,7 @@ src_install() {
systemd_dounit "${FILESDIR}/${PN}.service"
}
+
+pkg_postinst() {
+ systemd_reenable "${PN}.service"
+}
diff --git a/x11-misc/lightdm/lightdm-1.24.0-r1.ebuild b/x11-misc/lightdm/lightdm-1.24.0-r1.ebuild
index 3a6907106062..ae3715bded41 100644
--- a/x11-misc/lightdm/lightdm-1.24.0-r1.ebuild
+++ b/x11-misc/lightdm/lightdm-1.24.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -128,3 +128,7 @@ src_install() {
systemd_dounit "${FILESDIR}/${PN}.service"
}
+
+pkg_postinst() {
+ systemd_reenable "${PN}.service"
+}