summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-06-03 13:27:37 -0700
committerMatt Turner <mattst88@gentoo.org>2019-06-03 13:27:42 -0700
commit278bfd9bf3149d6e00d3b8b91595005583511a3f (patch)
tree3a60bc6b2d144597ec08926710d79769be3299df /x11-misc
parentx11-base/xorg-server: Add missing XORG_EAUTORECONF=yes (diff)
downloadgentoo-278bfd9bf3149d6e00d3b8b91595005583511a3f.tar.gz
gentoo-278bfd9bf3149d6e00d3b8b91595005583511a3f.tar.bz2
gentoo-278bfd9bf3149d6e00d3b8b91595005583511a3f.zip
x11-misc/xkeyboard-config: Version bump to 2.27
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xkeyboard-config/Manifest1
-rw-r--r--x11-misc/xkeyboard-config/xkeyboard-config-2.27.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/x11-misc/xkeyboard-config/Manifest b/x11-misc/xkeyboard-config/Manifest
index 9e15000f7a6c..d59ff364863f 100644
--- a/x11-misc/xkeyboard-config/Manifest
+++ b/x11-misc/xkeyboard-config/Manifest
@@ -1,2 +1,3 @@
DIST xkeyboard-config-2.25.tar.bz2 1055253 BLAKE2B 80de6393f7dc2af18c4ef0e31458c4ff10333213fc109e01db809f8362af53315601e276ed856edf0b15e264b499f6335c380cc33ba6e11448e686c6a0295fa0 SHA512 2d9d6bdd885edc8e03e5a2c136c3b29b4ea795122709fa210bf151c4e7416a44fa2928bb29137ee8c6691d8646c1f645748576dea3f940ce84c8d4d0f91e09eb
DIST xkeyboard-config-2.26.tar.bz2 1061733 BLAKE2B d07bbe28d5621aa146fdca089f60ebf293aa9b39b60fb6f7335cef934ff9edc6a11475ff00b7279a960cd9941f91260f25b7502fbe421bd8bf5c0da53f7a3471 SHA512 5c8a31f7a6ad5daed8a3fceb56230b2e2fc04a25f52a43b3b4ea81e4a6ab15c52869f749c4b747d855cd4b618c04bcbb40e85dec7eab31fbe3bd45e8c9b755ef
+DIST xkeyboard-config-2.27.tar.bz2 1664454 BLAKE2B ac5e02903f46579a1df0423c01d2c07412642d00a5e73b05c0d112e4a65163c20c2df762438775afc52445eed47025c8e061fa0945140245679b693d740e904c SHA512 ae29177461f9d2c6ce1c56c0b8b147600e3f0ecd15e8754c9531811702d9a030a31f42679a88a9fb706bec458974c337ee2a0180f22573702caa7184eb94017e
diff --git a/x11-misc/xkeyboard-config/xkeyboard-config-2.27.ebuild b/x11-misc/xkeyboard-config/xkeyboard-config-2.27.ebuild
new file mode 100644
index 000000000000..18bac7384839
--- /dev/null
+++ b/x11-misc/xkeyboard-config/xkeyboard-config-2.27.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="X keyboard configuration database"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/XKeyboardConfig https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config.git"
+ inherit autotools git-r3
+ # x11-misc/util-macros only required on live ebuilds
+ LIVE_DEPEND=">=x11-misc/util-macros-1.18"
+else
+ SRC_URI="mirror://xorg/data/${PN}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+RDEPEND="
+ !<x11-apps/xkbcomp-1.2.3
+ !<x11-libs/libX11-1.4.3
+"
+DEPEND="
+ ${LIVE_DEPEND}
+"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ local econfargs=(
+ --with-xkb-base="${EPREFIX}/usr/share/X11/xkb"
+ --enable-compat-rules
+ # do not check for runtime deps
+ --disable-runtime-deps
+ --with-xkb-rules-symlink=xorg
+ )
+
+ econf "${econfargs[@]}"
+}