summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-01-09 19:35:18 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-01-09 19:35:36 +0000
commit281ede10cf1df3f52943a53521ac3f0770d0ac3a (patch)
treeae76e77665579fc0456890ab613633bcd3cb6674 /x11-misc
parentRemove old (diff)
downloadgentoo-281ede10cf1df3f52943a53521ac3f0770d0ac3a.tar.gz
gentoo-281ede10cf1df3f52943a53521ac3f0770d0ac3a.tar.bz2
gentoo-281ede10cf1df3f52943a53521ac3f0770d0ac3a.zip
x11-misc/kbdd: update to EAPI=5
Package-Manager: portage-2.2.26
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/kbdd/kbdd-0.7-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-misc/kbdd/kbdd-0.7-r1.ebuild b/x11-misc/kbdd/kbdd-0.7-r1.ebuild
new file mode 100644
index 000000000000..a6b931354583
--- /dev/null
+++ b/x11-misc/kbdd/kbdd-0.7-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils vcs-snapshot
+
+DESCRIPTION="Very simple layout switcher"
+HOMEPAGE="https://github.com/qnikst/kbdd"
+SRC_URI="https://github.com/qnikst/kbdd/tarball/v${PV} -> ${PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus"
+
+DEPEND="dev-libs/glib:2=
+ x11-libs/libX11:0=
+ dbus? (
+ sys-apps/dbus:0=
+ >=dev-libs/dbus-glib-0.86:0=
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/kbdd-0.7-fix-non-dbus-build.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable dbus)
+}