summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <sudinave@gmail.com>2021-04-14 09:29:09 -0400
committerJoonas Niilola <juippis@gentoo.org>2021-04-15 09:38:57 +0300
commit440dd6f39522f63bf3e0678f5b8cfe9e97a15fff (patch)
treeb47caccdaa798941a0e0541bd0e131b041ac4e9f /x11-misc
parentx11-misc/xtitle: fix build with -native-symlinks (diff)
downloadgentoo-440dd6f39522f63bf3e0678f5b8cfe9e97a15fff.tar.gz
gentoo-440dd6f39522f63bf3e0678f5b8cfe9e97a15fff.tar.bz2
gentoo-440dd6f39522f63bf3e0678f5b8cfe9e97a15fff.zip
x11-misc/xtoolwait: fix build with -native-symlinks
Closes: https://bugs.gentoo.org/726226 Signed-off-by: Ionen Wolkens <sudinave@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xtoolwait/xtoolwait-1.3-r2.ebuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/x11-misc/xtoolwait/xtoolwait-1.3-r2.ebuild b/x11-misc/xtoolwait/xtoolwait-1.3-r2.ebuild
index 386962ee9765..379b2beb3faf 100644
--- a/x11-misc/xtoolwait/xtoolwait-1.3-r2.ebuild
+++ b/x11-misc/xtoolwait/xtoolwait-1.3-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,23 +16,21 @@ KEYWORDS="amd64 ppc x86"
RDEPEND="
x11-libs/libX11
x11-libs/libXext"
-DEPEND="${RDEPEND}
- x11-base/xorg-proto"
+DEPEND="${RDEPEND}"
BDEPEND="
app-text/rman
- x11-misc/imake"
+ x11-base/xorg-proto
+ >=x11-misc/imake-1.0.8-r1"
src_configure() {
- xmkmf || die
- sed -i \
- -e '/CC = /d' -e '/EXTRA_LDOPTIONS = /d' \
- Makefile || die
+ CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
+ IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf || die
}
src_compile() {
emake \
CC="$(tc-getCC)" \
- CCOPTIONS="${CFLAGS}" \
+ CDEBUGFLAGS="${CFLAGS}" \
EXTRA_LDOPTIONS="${LDFLAGS}"
}