summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2019-12-10 10:26:12 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2019-12-10 10:26:22 +0100
commit4ea1dee39f8e443d65e1a13f28b25e6a50d5d147 (patch)
tree74c39d401b3a6a587e8f3d8c99212fe6479b4ed1 /x11-misc
parentsys-fs/mergerfs-2.28.3-r1: make xattr opt-out. (diff)
downloadgentoo-4ea1dee39f8e443d65e1a13f28b25e6a50d5d147.tar.gz
gentoo-4ea1dee39f8e443d65e1a13f28b25e6a50d5d147.tar.bz2
gentoo-4ea1dee39f8e443d65e1a13f28b25e6a50d5d147.zip
x11-misc/picom: fix compilation with USE=-opengl
Closes: https://bugs.gentoo.org/702376 Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/picom/files/picom-7.5-no_opengl.patch27
-rw-r--r--x11-misc/picom/picom-7.5.ebuild4
2 files changed, 31 insertions, 0 deletions
diff --git a/x11-misc/picom/files/picom-7.5-no_opengl.patch b/x11-misc/picom/files/picom-7.5-no_opengl.patch
new file mode 100644
index 000000000000..ca9f715140ee
--- /dev/null
+++ b/x11-misc/picom/files/picom-7.5-no_opengl.patch
@@ -0,0 +1,27 @@
+From bd5a5fb56812ee5644e4c4bd1fdd82b9899317a7 Mon Sep 17 00:00:00 2001
+From: Jan Beich <jbeich@FreeBSD.org>
+Date: Sat, 12 Oct 2019 13:29:10 +0000
+Subject: [PATCH] Unbreak -Dopengl=false clean build
+
+In file included from ../src/x.c:17:
+../src/backend/gl/glx.h:10:10: fatal error: 'GL/glx.h' file not found
+ #include <GL/glx.h>
+ ^~~~~~~~~~
+---
+ src/x.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/x.c b/src/x.c
+index ed6668a8..2f802f1e 100644
+--- a/src/x.c
++++ b/src/x.c
+@@ -14,7 +14,9 @@
+ #include <xcb/xfixes.h>
+
+ #include "atom.h"
++#ifdef CONFIG_OPENGL
+ #include "backend/gl/glx.h"
++#endif
+ #include "common.h"
+ #include "compiler.h"
+ #include "kernel.h"
diff --git a/x11-misc/picom/picom-7.5.ebuild b/x11-misc/picom/picom-7.5.ebuild
index bec768b6fec8..5c07720ed5f7 100644
--- a/x11-misc/picom/picom-7.5.ebuild
+++ b/x11-misc/picom/picom-7.5.ebuild
@@ -39,6 +39,10 @@ DEPEND="${RDEPEND}
BDEPEND="virtual/pkgconfig
doc? ( app-text/asciidoc )"
+PATCHES=(
+ "${FILESDIR}"/${P}-no_opengl.patch
+ )
+
src_configure() {
local emesonargs=(
$(meson_use config-file config_file)