summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2022-12-18 20:08:13 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2022-12-18 20:12:19 +0100
commit654c734fe30d77ea6687840f074f802886995080 (patch)
tree2a39f1b5391382bcb4889d29c99219926d09c527 /x11-misc
parentsys-boot/unetbootin: Stabilize 702 amd64, #886793 (diff)
downloadgentoo-654c734fe30d77ea6687840f074f802886995080.tar.gz
gentoo-654c734fe30d77ea6687840f074f802886995080.tar.bz2
gentoo-654c734fe30d77ea6687840f074f802886995080.zip
x11-misc/picom: add 10.2
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/picom/Manifest1
-rw-r--r--x11-misc/picom/picom-10.2.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/x11-misc/picom/Manifest b/x11-misc/picom/Manifest
index d68393ea8f31..28a2e222497e 100644
--- a/x11-misc/picom/Manifest
+++ b/x11-misc/picom/Manifest
@@ -1,2 +1,3 @@
DIST picom-10.1.tar.gz 286934 BLAKE2B 0a6637c5615cfed514b746d85c2627b398fb0dd45b1027967b5145e1309e9ec4f2ac2e77a1459c06cb1db70fa3b12c350f42c6a0299ae7e4acc41270ca88dbbd SHA512 6c97f0f0665be5cd38f844d0902cc7cac7f97af578f9df585aaa43b5f7b0a20c3660a2fcb44b1af5ae87407f4a0691c976ab1e6ad09939f385c3bcb8c0d4a351
+DIST picom-10.2.tar.gz 287166 BLAKE2B feaa07fc5f0a53396675dfd4d8f2507caf6ce355b2db242b25b3559b287845b0505c48194e51c9c7fc6809dd10b871be6adf3e9fc87d91a41f01ccfeb87803ab SHA512 9c0351fbe8a9e76533243c8e76f8e7d10c1e49292f1c8e6c06f31fb0b512542a67970abe803d061c953546ff8d3e704488c263002a5a831f68deb010caee481d
DIST picom-9.1.tar.gz 263924 BLAKE2B 093f2fe12f3388b7979379d2e2b695a779cc9ebf95cbfa5b4f39c4fcc7cd6fc82be662bb9b0355fbadca66c0b0d7ac0d1e463272b0dbe4bbcca985691b6255e9 SHA512 375dc245be1c0f277bc0ddfc6e6480255efba06ce49f953c5314b7ba9795d1f50c5de907762208becc13c5210f24ac5b2241e2eb5e0e10dc5e5b96081cc821df
diff --git a/x11-misc/picom/picom-10.2.ebuild b/x11-misc/picom/picom-10.2.ebuild
new file mode 100644
index 000000000000..4fbfa13e77d8
--- /dev/null
+++ b/x11-misc/picom/picom-10.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit meson python-any-r1 virtualx xdg
+
+DESCRIPTION="A lightweight compositor for X11 (previously a compton fork)"
+HOMEPAGE="https://github.com/yshui/picom"
+SRC_URI="https://github.com/yshui/picom/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="+config-file dbus +doc +drm opengl pcre test"
+
+REQUIRED_USE="test? ( dbus )" # avoid "DBus support not compiled in!"
+RESTRICT="test" # but tests require dbus_next
+
+RDEPEND="dev-libs/libev
+ dev-libs/uthash
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXext
+ x11-libs/pixman
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-renderutil
+ config-file? (
+ dev-libs/libconfig:=
+ )
+ dbus? ( sys-apps/dbus )
+ drm? ( x11-libs/libdrm )
+ opengl? ( virtual/opengl )
+ pcre? ( dev-libs/libpcre )
+ !x11-misc/compton"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig
+ doc? ( app-text/asciidoc )
+ test? ( $(python_gen_any_dep 'dev-python/xcffib[${PYTHON_USEDEP}]') )
+"
+
+DOCS=( README.md picom.sample.conf )
+
+python_check_deps() {
+ python_has_version "dev-python/xcffib[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use config-file config_file)
+ $(meson_use dbus)
+ $(meson_use doc with_docs)
+ $(meson_use opengl)
+ $(meson_use pcre regex)
+ )
+
+ meson_src_configure
+}
+
+src_test() {
+ virtx "${S}/tests/run_tests.sh" "${BUILD_DIR}/src/${PN}"
+}