summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2018-03-10 11:49:00 +1100
committerMichael Palimaka <kensington@gentoo.org>2018-03-10 11:49:07 +1100
commit65906287ba9f5de72f264c7b667177b269b9fe85 (patch)
tree56a2ce1e64752045c004dc9a9a4680611caf8941 /x11-misc
parentapp-text/ansifilter: version bump 2.10 (diff)
downloadgentoo-65906287ba9f5de72f264c7b667177b269b9fe85.tar.gz
gentoo-65906287ba9f5de72f264c7b667177b269b9fe85.tar.bz2
gentoo-65906287ba9f5de72f264c7b667177b269b9fe85.zip
x11-misc/albert: version bump 0.14.16
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/albert/Manifest2
-rw-r--r--x11-misc/albert/albert-0.14.16.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/x11-misc/albert/Manifest b/x11-misc/albert/Manifest
index 1500044e7996..6e357e0a5b55 100644
--- a/x11-misc/albert/Manifest
+++ b/x11-misc/albert/Manifest
@@ -1,2 +1,4 @@
DIST albert-0.14.15-plugins.tar.gz 540189 BLAKE2B b8243917cdd30c74f26ad852421cf525047694aaae2ec170a31d6239f7fa704de72f9ef67564282136ca15ec1960a1c882c193a2339541e0bf40986ee10588cb SHA512 1af59c65bd91ac626abd8777b350c92a4532a88119bd9ec6ff55f9f3ad72e5cfd6987c9b34f1c32ca854891e91f79ffbea04ed23fa85a18826e9aa890b400079
DIST albert-0.14.15.tar.gz 84875 BLAKE2B 80e173100a0d135a18b20482ef0eb103634207b1e1a7284b2c5245750bc22478026b25982b714b3fcd079ed7674075a6853917d789f99628a368c6a9c6fd344d SHA512 9a6efd9203f7b96aa14c063a9de8c59e6b4bb0a5c55a64662ec170b75fc71247b7313a1252f71ab2516b4b62538f4c89778a43b8804915996636f49d4e0a6d31
+DIST albert-0.14.16-plugins.tar.gz 540297 BLAKE2B e859ff84332fe32ca0513700dd3ee099ef99f240823c70387f630877f972fccf86baab477d0ec5fe166bb979fb6509e9a3ef5e9bb04ba365e789da74d3508555 SHA512 06cefb99ec2da0ccd4ad1f4729cb5626611ba3b226ccae9c8448ad2c58e61790dfd391dcd963524762587b82739f2267aea6b2a2b7affa4c946d6ba438678383
+DIST albert-0.14.16.tar.gz 84708 BLAKE2B e901518cf36fd3a68e6b5ddd4f0937ed0cff62f9a8e541b8319670893e2a38c47d222c6e3f25a9673bd1e11ad357382a3441e55497609d049f2b287c97ce6484 SHA512 92708909ed8a91ac2c16ba967c8506a15d4cc74cbb88111761ab18941c3bbab040f5b379b8c780887024b53710b05ad1ce80ffe41bd252358daf80c19b2c953b
diff --git a/x11-misc/albert/albert-0.14.16.ebuild b/x11-misc/albert/albert-0.14.16.ebuild
new file mode 100644
index 000000000000..3c586fcd9f58
--- /dev/null
+++ b/x11-misc/albert/albert-0.14.16.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PLUGINS_HASH="c92234731b5dae3baca6eb4e0561cd7ee90e7b56"
+inherit cmake-utils gnome2-utils
+
+DESCRIPTION="Desktop agnostic launcher"
+HOMEPAGE="https://albertlauncher.github.io/"
+# plugins is a git submodule. the hash is taken from the submodule reference in the ${PV} tag.
+SRC_URI="https://github.com/albertlauncher/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+https://github.com/albertlauncher/plugins/archive/${PLUGINS_HASH}.tar.gz -> ${P}-plugins.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug"
+
+RDEPEND="
+ dev-cpp/muParser
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ mv "${WORKDIR}"/plugins-${PLUGINS_HASH}/* "${S}"/plugins/ || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DEBUG=$(usex debug)
+ -DBUILD_PYTHON=OFF #plugin directory is empty causing build failure
+ -DBUILD_VIRTUALBOX=OFF #plugin needs virtualbox installed to build, untested
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}