summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKajzer <kajzersoze72@gmail.com>2018-05-04 12:59:23 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-05-04 23:05:07 +0200
commit6d597a32e22e77dc620678702aad9c14e44d2978 (patch)
tree8533a33f30710f8f8b0de086b994b140dd5f69d2 /x11-misc
parentdev-lang/php: Fix building with freetype 2.9.1 by using pkgconfig (diff)
downloadgentoo-6d597a32e22e77dc620678702aad9c14e44d2978.tar.gz
gentoo-6d597a32e22e77dc620678702aad9c14e44d2978.tar.bz2
gentoo-6d597a32e22e77dc620678702aad9c14e44d2978.zip
x11-misc/polybar: new package.
Polybar is a fast and easy-to-use tool for creating status bars. Closes: https://github.com/gentoo/gentoo/pull/8244 Closes: https://bugs.gentoo.org/643286
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/polybar/Manifest3
-rw-r--r--x11-misc/polybar/metadata.xml21
-rw-r--r--x11-misc/polybar/polybar-3.1.0.ebuild63
-rw-r--r--x11-misc/polybar/polybar-9999.ebuild48
4 files changed, 135 insertions, 0 deletions
diff --git a/x11-misc/polybar/Manifest b/x11-misc/polybar/Manifest
new file mode 100644
index 000000000000..4648dddbc079
--- /dev/null
+++ b/x11-misc/polybar/Manifest
@@ -0,0 +1,3 @@
+DIST i3ipcpp-0.7.1.tar.gz 191417 BLAKE2B 62b76a0921c78f374309d26856c01d1467b8bd181ce922fd47daec406afda9d76eea9a1f473b4899e22f99e2ef36fc70f72db1bb17eb1f3e71a8431c2634b915 SHA512 ef9f591bb4436916ad038bcb0c15ea3415d1978ff264fb276108ddac89c98515c464fbf252429f6a76589cb78e1434adba2efefb5a844dadad0e261f3806fb72
+DIST polybar-3.1.0.tar.gz 418298 BLAKE2B 1c7394a17ff1ec5b0dec519b7aa58e63cfcec0f104d4302051f6e12753b7074c3d85072a3d78e7ce135c53d4ddd4a6f68ea61ffb7b2ad04997bbf0c836115046 SHA512 6d8759d9f750c2abfa79fe735615b0ed3d1827e3a88561317712c6f02cb32a0a77726f97cb419f3a040ae9085a34a23cb1aad0aacf3f14e56c542977b89036b2
+DIST xpp-1.4.0.tar.gz 84095 BLAKE2B 2af4221953abe7f40473c55cd50c608b54ebc85a62be65af987ed5e6c5eaf56fbd92531788becf39ba5ad52099ac78f36e9b2a2515b473f4d86ed5fda3fa5065 SHA512 d34cbbe2391db36db7dffac0415d26b7487536e97c4d7efd472ab0aeffa4c8e757ee030b05e2aa1cfa8a591ee591bb96a6db7eb9fa5850027f958e92f078739c
diff --git a/x11-misc/polybar/metadata.xml b/x11-misc/polybar/metadata.xml
new file mode 100644
index 000000000000..4132afb3b38d
--- /dev/null
+++ b/x11-misc/polybar/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>kajzersoze72@gmail.com</email>
+ <name>Kajzer</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="i3wm">Add support for i3 window manager</flag>
+ <flag name="ipc">Add support for Inter-Process Messaging</flag>
+ <flag name="mpd">Add support for Music Player Daemon</flag>
+ <flag name="network">Enable network support</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">jaagr/polybar</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/polybar/polybar-3.1.0.ebuild b/x11-misc/polybar/polybar-3.1.0.ebuild
new file mode 100644
index 000000000000..a04e956a0e9e
--- /dev/null
+++ b/x11-misc/polybar/polybar-3.1.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils python-single-r1
+
+XPP_VERSION="1.4.0"
+I3IPCPP_VERSION="0.7.1"
+
+DESCRIPTION="A fast and easy-to-use tool for creating status bars"
+HOMEPAGE="https://github.com/jaagr/polybar"
+SRC_URI="https://github.com/jaagr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/jaagr/xpp/archive/${XPP_VERSION}.tar.gz -> xpp-${XPP_VERSION}.tar.gz
+ https://github.com/jaagr/i3ipcpp/archive/v${I3IPCPP_VERSION}.tar.gz -> i3ipcpp-${I3IPCPP_VERSION}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="alsa curl i3wm ipc mpd network"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ x11-base/xcb-proto
+ x11-libs/libxcb
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-image
+ alsa? ( media-libs/alsa-lib )
+ curl? ( net-misc/curl )
+ i3wm? ( dev-libs/jsoncpp )
+ mpd? ( media-libs/libmpdclient )
+ network? ( net-wireless/wireless-tools )
+"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ rmdir "${S}"/lib/xpp || die
+ mv "${WORKDIR}"/xpp-$XPP_VERSION "${S}"/lib/xpp || die
+
+ rmdir "${S}"/lib/i3ipcpp || die
+ mv "${WORKDIR}"/i3ipcpp-$I3IPCPP_VERSION "${S}"/lib/i3ipcpp || die
+
+ sed -i "s/.*cpp_error,.*/&\n\t 'eventstruct' : lambda x, y: None,/" lib/xpp/generators/cpp_client.py || die "sed failed"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_ALSA="$(usex alsa)"
+ -DENABLE_CURL="$(usex curl)"
+ -DENABLE_I3="$(usex i3wm)"
+ -DBUILD_IPC_MSG="$(usex ipc)"
+ -DENABLE_MPD="$(usex mpd)"
+ -DENABLE_NETWORK="$(usex network)"
+ )
+ cmake-utils_src_configure
+}
diff --git a/x11-misc/polybar/polybar-9999.ebuild b/x11-misc/polybar/polybar-9999.ebuild
new file mode 100644
index 000000000000..b21888340078
--- /dev/null
+++ b/x11-misc/polybar/polybar-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils git-r3 python-single-r1
+
+DESCRIPTION="A fast and easy-to-use tool for creating status bars"
+HOMEPAGE="https://github.com/jaagr/polybar"
+EGIT_REPO_URI="https://github.com/jaagr/${PN}.git"
+EGIT_CLONE_TYPE="shallow"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+
+IUSE="alsa curl i3wm ipc mpd network pulseaudio"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ x11-base/xcb-proto
+ x11-libs/libxcb
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-image
+ alsa? ( media-libs/alsa-lib )
+ curl? ( net-misc/curl )
+ i3wm? ( dev-libs/jsoncpp )
+ mpd? ( media-libs/libmpdclient )
+ network? ( net-wireless/wireless-tools )
+ pulseaudio? ( media-sound/pulseaudio )
+"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_ALSA="$(usex alsa)"
+ -DENABLE_CURL="$(usex curl)"
+ -DENABLE_I3="$(usex i3wm)"
+ -DBUILD_IPC_MSG="$(usex ipc)"
+ -DENABLE_MPD="$(usex mpd)"
+ -DENABLE_NETWORK="$(usex network)"
+ -DENABLE_PULSEAUDIO="$(usex pulseaudio)"
+ )
+ cmake-utils_src_configure
+}