summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-04-23 10:03:13 +0200
committerDavid Seifert <soap@gentoo.org>2018-04-24 11:21:07 +0200
commit7f3a7dcf03ffa9693cddae427b495712afb72c47 (patch)
tree9f890364e9420570d0183dd42fb9bd6dd67e50ca /x11-misc
parentsys-devel/gdb: explicit epatch, git-2->git-r3, EAPI=6 (diff)
downloadgentoo-7f3a7dcf03ffa9693cddae427b495712afb72c47.tar.gz
gentoo-7f3a7dcf03ffa9693cddae427b495712afb72c47.tar.bz2
gentoo-7f3a7dcf03ffa9693cddae427b495712afb72c47.zip
x11-misc/slop: Version bump to 7.4
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/slop/Manifest1
-rw-r--r--x11-misc/slop/slop-7.4.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/x11-misc/slop/Manifest b/x11-misc/slop/Manifest
index eae40123c514..2ed1af945a0c 100644
--- a/x11-misc/slop/Manifest
+++ b/x11-misc/slop/Manifest
@@ -1 +1,2 @@
DIST slop-6.3.46.tar.gz 89391 BLAKE2B 0150ca63e4a598e892abd5505e867f01204f29796dc378a7f3d0c041c1a27f000e98962c41cbf8109573575b37449c1869f29f988c5d2046b504382b2a56779d SHA512 9f44bbb8e14e71a17858711d8da902cb9cf5dc65ed47284be15122f2d1793544deab7f0700517bd07e44613662bfbc7f0991f3d36dcf74af6f90de5fbbd79558
+DIST slop-7.4.tar.gz 50079 BLAKE2B 20815270bf1bffe0ef26630fd31d0d4cc7261633cef389e64c232a89033b6e8b5e1651fb5c882e2870808107734c4c088123b85675fa2aae932570d770344dc8 SHA512 13d09c2c9f05760ee0a273edb6d40da8a87989d3f071a8c868a0c7e535ba89b9eb934c79d56212cd689687f86e3683cef1b749ef7b37be3805ea8eb05c796e58
diff --git a/x11-misc/slop/slop-7.4.ebuild b/x11-misc/slop/slop-7.4.ebuild
new file mode 100644
index 000000000000..a61629c541d3
--- /dev/null
+++ b/x11-misc/slop/slop-7.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+inherit cmake-utils
+
+DESCRIPTION="An application that queries the user for a selection for printing"
+HOMEPAGE="https://github.com/naelstrof/slop"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/naelstrof/slop.git"
+else
+ SRC_URI="https://github.com/naelstrof/slop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+IUSE="opengl"
+
+RDEPEND="
+ dev-libs/icu:=
+ x11-libs/libX11
+ x11-libs/libXext
+ opengl? (
+ media-libs/glew:0=
+ virtual/opengl
+ x11-libs/libXrender:=
+ )"
+DEPEND="
+ ${RDEPEND}
+ media-libs/glm"
+
+src_configure() {
+ local mycmakeargs=(
+ -DSLOP_OPENGL=$(usex opengl)
+ )
+ cmake-utils_src_configure
+}