summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Denoncin <ddenoncin@gmail.com>2020-08-02 16:25:57 +0200
committerSam James <sam@gentoo.org>2020-08-03 02:58:23 +0000
commit805525bbecce584afed1ab992546ac9c1c446616 (patch)
treee7df9c847ac80d8cba2eecfcd8e99e32656f0b3a /x11-misc
parentx11-misc/xfractint: new proxy maintainer (diff)
downloadgentoo-805525bbecce584afed1ab992546ac9c1c446616.tar.gz
gentoo-805525bbecce584afed1ab992546ac9c1c446616.tar.bz2
gentoo-805525bbecce584afed1ab992546ac9c1c446616.zip
x11-misc/xfractint: vbump 20.04p16, bug fixes
Closes:https://bugs.gentoo.org/706522 Closes:https://bugs.gentoo.org/732432 Closes:https://bugs.gentoo.org/715712 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: David Denoncin <ddenoncin@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/16675 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xfractint/Manifest1
-rw-r--r--x11-misc/xfractint/files/xfractint-20.04p16-install-phase.patch24
-rw-r--r--x11-misc/xfractint/xfractint-20.04_p16.ebuild37
3 files changed, 62 insertions, 0 deletions
diff --git a/x11-misc/xfractint/Manifest b/x11-misc/xfractint/Manifest
index 89b57a273ede..c3ee4387259d 100644
--- a/x11-misc/xfractint/Manifest
+++ b/x11-misc/xfractint/Manifest
@@ -1 +1,2 @@
DIST xfractint-20.04p14.tar.gz 1336285 BLAKE2B 946c34551acf131845f1ecf17d4fe82214535627e8ea68d704efcff4b93c525d82f004bde8ae1bac11df8c82caa3bcff4778b2f8dfed1bdb494ba036e62256c5 SHA512 7d13c719f4f4b0680455b9b7f86644928d8145606973d208e5bf0d26b4f7b04ddbf8d2080ea35c872b21e079f1a116f3ef94e9acb36a45d43c16403c473e2acd
+DIST xfractint-20.04p16.tar.gz 1356976 BLAKE2B 2cb05021c76d9761bf7020a2b9a0fbf7d682a620d931b7841ce75780c1a3aabb6bbbd1b2e378fba3e96b2cfdaf845ff9cdafcf3219ee756fe7d128a19b342132 SHA512 6696daf21c2927d87f58f7d7136c5d51bd8c60d78e901d537f1ef38f27b70c42a590b05c663363c49a8cb30d7013a969813e7bbe4a97f49b9c286497b440bdf1
diff --git a/x11-misc/xfractint/files/xfractint-20.04p16-install-phase.patch b/x11-misc/xfractint/files/xfractint-20.04p16-install-phase.patch
new file mode 100644
index 000000000000..0387b63b7e43
--- /dev/null
+++ b/x11-misc/xfractint/files/xfractint-20.04p16-install-phase.patch
@@ -0,0 +1,24 @@
+Prevents recompiling in install phase and sets default
+CC if not set
+Fix by David Denoncin
+
+--- a/Makefile 2020-08-01 23:19:09.000000000 -0000
++++ b/Makefile 2020-08-02 14:33:52.943061996 -0000
+@@ -150,7 +150,7 @@
+ # For Sun Solaris 2.x w/GNU gcc, use CC = gcc
+ #CC = gcc
+ #CC = /usr/bin/gcc
+-CC ?=
++CC ?= /usr/bin/gcc
+
+ # For HPUX, use LIBS = -L/usr/lib/X11R4 -lX11 -lm -lcurses -ltermcap
+ # For AIX or OSF/1, add -lbsd
+@@ -345,7 +345,7 @@
+ cd $(COMDIR) ; ${MAKE} clean
+ cd $(UDIR) ; ${MAKE} clean "AS=${AS}"
+
+-install: xfractint fractint.hlp
++install:
+ # $(STRIP) xfractint
+ $(INSTALL) -d $(BINDIR) $(MANDIR) $(SRCDIR)/$(PDIR) $(SRCDIR)/$(FDIR) \
+ $(SRCDIR)/$(IDIR) $(SRCDIR)/$(LDIR) $(SRCDIR)/$(MDIR) $(SRCDIR)/$(XDIR)
diff --git a/x11-misc/xfractint/xfractint-20.04_p16.ebuild b/x11-misc/xfractint/xfractint-20.04_p16.ebuild
new file mode 100644
index 000000000000..020f7b4a30a9
--- /dev/null
+++ b/x11-misc/xfractint/xfractint-20.04_p16.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_P=${P/_}
+
+DESCRIPTION="A fractal generator"
+HOMEPAGE="https://www.fractint.org"
+SRC_URI="https://www.fractint.org/ftp/current/linux/${MY_P}.tar.gz"
+
+LICENSE="free-noncomm HPND public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="x11-libs/libX11"
+
+DEPEND="
+ ${RDEPEND}
+ x11-libs/libXft
+"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-20.04p16-install-phase.patch"
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)" AS="$(tc-getAS)" OPT="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${ED}/usr" install
+}