summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-21 13:29:45 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-21 13:37:41 +0200
commit8d19c19cbf1f71e74c7fc6ea7489c6dc6fa6fbd2 (patch)
treef38def574727536c4fb79a239b5b64556c5c4afd /x11-misc
parentgames-board/cockatrice: Fix build with Qt 5.15 (diff)
downloadgentoo-8d19c19cbf1f71e74c7fc6ea7489c6dc6fa6fbd2.tar.gz
gentoo-8d19c19cbf1f71e74c7fc6ea7489c6dc6fa6fbd2.tar.bz2
gentoo-8d19c19cbf1f71e74c7fc6ea7489c6dc6fa6fbd2.zip
x11-misc/fraqtive: Fix build with Qt 5.15
Closes: https://bugs.gentoo.org/726776 Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/fraqtive/files/fraqtive-0.4.8-qt-5.15.patch39
-rw-r--r--x11-misc/fraqtive/fraqtive-0.4.8-r2.ebuild6
2 files changed, 44 insertions, 1 deletions
diff --git a/x11-misc/fraqtive/files/fraqtive-0.4.8-qt-5.15.patch b/x11-misc/fraqtive/files/fraqtive-0.4.8-qt-5.15.patch
new file mode 100644
index 000000000000..63c281757096
--- /dev/null
+++ b/x11-misc/fraqtive/files/fraqtive-0.4.8-qt-5.15.patch
@@ -0,0 +1,39 @@
+From 34963f986f64d98b6ef82757ca07159a6a059763 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sun, 21 Jun 2020 13:21:15 +0200
+Subject: [PATCH] Fix build with Qt 5.15 (missing QPainterPath include)
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ src/datafunctions.cpp | 2 ++
+ src/shadewidget.cpp | 1 +
+ 2 files changed, 3 insertions(+)
+
+diff --git a/src/datafunctions.cpp b/src/datafunctions.cpp
+index 3ec1af9..9369299 100644
+--- a/src/datafunctions.cpp
++++ b/src/datafunctions.cpp
+@@ -19,6 +19,8 @@
+ #include "datafunctions.h"
+ #include "fractaldata.h"
+
++#include <QPainterPath>
++
+ namespace DataFunctions
+ {
+
+diff --git a/src/shadewidget.cpp b/src/shadewidget.cpp
+index 1494b37..3da5c05 100644
+--- a/src/shadewidget.cpp
++++ b/src/shadewidget.cpp
+@@ -19,6 +19,7 @@
+ #include "shadewidget.h"
+
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QPaintEvent>
+ #include <QToolTip>
+
+--
+2.27.0
+
diff --git a/x11-misc/fraqtive/fraqtive-0.4.8-r2.ebuild b/x11-misc/fraqtive/fraqtive-0.4.8-r2.ebuild
index 7c98c2069002..0b5059a75c4d 100644
--- a/x11-misc/fraqtive/fraqtive-0.4.8-r2.ebuild
+++ b/x11-misc/fraqtive/fraqtive-0.4.8-r2.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit qmake-utils toolchain-funcs xdg
DESCRIPTION="Open source, multi-platform generator of the Mandelbrot family fractals"
@@ -25,7 +26,10 @@ DEPEND="
"
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}/${P}-qt-includes.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-qt-includes.patch"
+ "${FILESDIR}/${P}-qt-5.15.patch"
+)
src_configure() {
tc-export PKG_CONFIG