summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetrus.Z <silencly07@gmail.com>2021-10-09 13:53:06 +0800
committerFlorian Schmaus <flow@gentoo.org>2021-10-10 11:25:24 +0200
commit9fed0ccf36b2ad2036d6ae10da11dd13f44ad47c (patch)
tree293841d3c7989528836c95fb3649b1cd33e6ac52 /x11-misc
parentx11-misc/sxhkd: drop 0.6.1 (diff)
downloadgentoo-9fed0ccf36b2ad2036d6ae10da11dd13f44ad47c.tar.gz
gentoo-9fed0ccf36b2ad2036d6ae10da11dd13f44ad47c.tar.bz2
gentoo-9fed0ccf36b2ad2036d6ae10da11dd13f44ad47c.zip
x11-misc/rofi: version bump to 1.7.0
Package-Manager: Portage-3.0.26, Repoman-3.0.3 Signed-off-by: Petrus Zhao <petrus.zy.07@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/22524 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/rofi/Manifest1
-rw-r--r--x11-misc/rofi/metadata.xml27
-rw-r--r--x11-misc/rofi/rofi-1.7.0.ebuild66
3 files changed, 86 insertions, 8 deletions
diff --git a/x11-misc/rofi/Manifest b/x11-misc/rofi/Manifest
index 4786f50a50b8..6c71b2feda60 100644
--- a/x11-misc/rofi/Manifest
+++ b/x11-misc/rofi/Manifest
@@ -1 +1,2 @@
DIST rofi-1.6.1.tar.gz 569262 BLAKE2B 938b45f8326b5a28e349ac9f7028c476274faa4f932a773acc350d5e1dc8d5c05c7cfb7ec10f1ab5d8c83590074424c3379768671d37ee799d78e508b8c4a4cb SHA512 b54e75818a98fa9262a3016260051837de189d49beff4f4a158cb2e7f41438641377e11d75c164f423e6a86d8b8fca3b76e2630611678525465d06c21b393f60
+DIST rofi-1.7.0.tar.gz 902294 BLAKE2B 281f48702650f65e4b037fdbbe6861e173dd3465cf6a80a1d2038271511a9f85ebdb19d8e7a1854f82d52172bbfea6eb1b1685228fc4ff874773033406c9267b SHA512 84a42ecf519c7eed8093c4af3b66731b890939a2bf2a63290e599103705f6bacaba59ade1b8a1bc854f6b767e8d44ee42c20e44f63886bcacbfdbe0468d350b4
diff --git a/x11-misc/rofi/metadata.xml b/x11-misc/rofi/metadata.xml
index 87511edddce1..040d877273ac 100644
--- a/x11-misc/rofi/metadata.xml
+++ b/x11-misc/rofi/metadata.xml
@@ -1,12 +1,23 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
-<use>
-<flag name="drun">Enable desktop file run dialog</flag>
-<flag name="windowmode">Enable normal window mode</flag>
-</use>
-<upstream>
-<remote-id type="github">DaveDavenport/rofi</remote-id>
-</upstream>
+ <maintainer type="person" proxied="yes">
+ <email>petrus.zy.07@gmail.com</email>
+ <name>Petrus Zhao</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="person">
+ <name>Florian Schmaus</name>
+ <email>flow@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="drun">Enable desktop file run dialog</flag>
+ <flag name="windowmode">Enable normal window mode</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">DaveDavenport/rofi</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/x11-misc/rofi/rofi-1.7.0.ebuild b/x11-misc/rofi/rofi-1.7.0.ebuild
new file mode 100644
index 000000000000..bfa3300d765f
--- /dev/null
+++ b/x11-misc/rofi/rofi-1.7.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="A window switcher, run dialog and dmenu replacement"
+HOMEPAGE="https://github.com/davatorium/rofi"
+SRC_URI="https://github.com/davatorium/rofi/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+drun test +windowmode"
+RESTRICT="!test? ( test )"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ dev-libs/glib:2
+ gnome-base/librsvg:2
+ media-libs/freetype
+ virtual/jpeg
+ x11-libs/cairo[X,xcb(+)]
+ x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libxcb
+ x11-libs/libxkbcommon[X]
+ x11-libs/pango[X]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-xrm
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+ test? ( >=dev-libs/check-0.11 )
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+
+ local myeconfargs=(
+ $(use_enable drun)
+ $(use_enable test check)
+ $(use_enable windowmode)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+pkg_postinst() {
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test "${v}" -lt 1.7.0; then
+ elog "Rofi 1.7.0 removed the (deprecated) xresources based configuration setup."
+ elog "If you are still using old configuration setup, please convert it to new format manually."
+ elog "The new format configuration can be generated by 'rofi -dump-config > ~/.config/rofi/config.rasi'."
+ elog "For more information, please see https://github.com/davatorium/rofi/releases/tag/1.7.0"
+ fi
+ done
+}