summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2020-10-11 11:19:51 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2020-10-11 11:19:51 +0300
commita1ae67275707d149aaf6daba5387dcbb2d94325c (patch)
tree42fc05423b7c7a8b00add22e96891d2320038b57 /x11-misc
parentx11-wm/e16: drop old (diff)
downloadgentoo-a1ae67275707d149aaf6daba5387dcbb2d94325c.tar.gz
gentoo-a1ae67275707d149aaf6daba5387dcbb2d94325c.tar.bz2
gentoo-a1ae67275707d149aaf6daba5387dcbb2d94325c.zip
x11-misc/e16menuedit2: fix build with -fno-common
Closes: https://bugs.gentoo.org/707426 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/e16menuedit2/e16menuedit2-0.0.3.ebuild7
-rw-r--r--x11-misc/e16menuedit2/files/e16menuedit2-no-common.patch20
2 files changed, 25 insertions, 2 deletions
diff --git a/x11-misc/e16menuedit2/e16menuedit2-0.0.3.ebuild b/x11-misc/e16menuedit2/e16menuedit2-0.0.3.ebuild
index e0d251548c59..9c379752fcbb 100644
--- a/x11-misc/e16menuedit2/e16menuedit2-0.0.3.ebuild
+++ b/x11-misc/e16menuedit2/e16menuedit2-0.0.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -24,7 +24,10 @@ DEPEND="
"
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}/${PN}-no-default-docs.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-no-default-docs.patch"
+ "${FILESDIR}/${PN}-no-common.patch"
+)
src_prepare() {
sed -i '1i#include <glib/gstdio.h>' src/e16menuedit2.c || die
diff --git a/x11-misc/e16menuedit2/files/e16menuedit2-no-common.patch b/x11-misc/e16menuedit2/files/e16menuedit2-no-common.patch
new file mode 100644
index 000000000000..4ac213b101f9
--- /dev/null
+++ b/x11-misc/e16menuedit2/files/e16menuedit2-no-common.patch
@@ -0,0 +1,20 @@
+--- e16menuedit2-0.0.3/src/e16menu.h.orig 2020-10-11 10:41:36.827021380 +0300
++++ e16menuedit2-0.0.3/src/e16menu.h 2020-10-11 10:51:27.043070842 +0300
+@@ -45,6 +45,6 @@
+ gboolean table_check_func (GtkTreeModel *model, GtkTreePath *path,
+ GtkTreeIter *iter, gpointer user_data);
+
+-gchar *menu_file[MAX_RECURSION];
++extern gchar *menu_file[MAX_RECURSION];
+
+ #endif /* _E16MENU_H */
+--- e16menuedit2-0.0.3/src/e16menu.c.orig 2005-02-18 15:09:55.000000000 +0300
++++ e16menuedit2-0.0.3/src/e16menu.c 2020-10-11 10:51:52.615152314 +0300
+@@ -34,6 +34,7 @@
+ #include "treeview.h"
+
+ extern struct global_variables gv;
++gchar *menu_file[MAX_RECURSION];
+
+ GtkTreeModel *load_menus_from_disk (void)
+ {