summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-02 10:57:18 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-02 11:13:41 +0200
commitab99b6be02c03c34b1315038efb01beb097197b5 (patch)
treed654b4a2af348740c03c11cb7aa6e15d346aed68 /x11-misc
parentmedia-gfx/replicatorg: gsettings-desktop-schemas needed (#494400) (diff)
downloadgentoo-ab99b6be02c03c34b1315038efb01beb097197b5.tar.gz
gentoo-ab99b6be02c03c34b1315038efb01beb097197b5.tar.bz2
gentoo-ab99b6be02c03c34b1315038efb01beb097197b5.zip
x11-misc/notify-osd: gsettings-desktop-schemas needed (#559010)
Package-Manager: Portage-2.3.27, Repoman-2.3.9
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/notify-osd/notify-osd-0.9.34-r1.ebuild (renamed from x11-misc/notify-osd/notify-osd-0.9.34.ebuild)31
1 files changed, 19 insertions, 12 deletions
diff --git a/x11-misc/notify-osd/notify-osd-0.9.34.ebuild b/x11-misc/notify-osd/notify-osd-0.9.34-r1.ebuild
index 70ae583ebe58..95bd82cc0720 100644
--- a/x11-misc/notify-osd/notify-osd-0.9.34.ebuild
+++ b/x11-misc/notify-osd/notify-osd-0.9.34-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit autotools gnome2-utils multilib savedconfig
+EAPI=6
+inherit autotools gnome2-utils savedconfig
DESCRIPTION="Canonical's on-screen-display notification agent"
HOMEPAGE="https://launchpad.net/notify-osd"
@@ -13,34 +13,39 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="minimal"
-COMMON_DEPEND=">=dev-libs/dbus-glib-0.98
- >=dev-libs/glib-2.16
+COMMON_DEPEND="
+ >=dev-libs/dbus-glib-0.98
+ >=dev-libs/glib-2.16:2
>=x11-libs/gtk+-3.2:3
>=x11-libs/libnotify-0.7
- >=x11-libs/libwnck-3
+ >=x11-libs/libwnck-3:3
x11-libs/libX11
x11-libs/pixman
!x11-misc/notification-daemon
- !x11-misc/qtnotifydaemon"
+ !x11-misc/qtnotifydaemon
+"
RDEPEND="${COMMON_DEPEND}
- !minimal? ( x11-themes/notify-osd-icons )"
+ gnome-base/gsettings-desktop-schemas
+ !minimal? ( x11-themes/notify-osd-icons )
+"
DEPEND="${COMMON_DEPEND}
virtual/pkgconfig
gnome-base/gnome-common
- x11-proto/xproto"
+ x11-proto/xproto
+"
RESTRICT="test" # virtualx.eclass: 1 of 1: FAIL: test-modules
-DOCS=( AUTHORS ChangeLog NEWS README TODO )
-
src_prepare() {
+ default
sed -i -e 's:noinst_PROG:check_PROG:' tests/Makefile.am || die
restore_config src/{bubble,defaults,dnd}.c #428134
+ mv configure.in configure.ac || die
eautoreconf
}
src_configure() {
- econf --libexecdir=/usr/$(get_libdir)/${PN}
+ econf --libexecdir="/usr/$(get_libdir)/${PN}"
}
src_install() {
@@ -53,10 +58,12 @@ pkg_preinst() {
gnome2_icon_savelist
gnome2_schemas_savelist
}
+
pkg_postinst() {
gnome2_icon_cache_update
gnome2_schemas_update
}
+
pkg_postrm() {
gnome2_icon_cache_update
gnome2_schemas_update