summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-07-18 14:18:05 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-07-18 14:20:09 -0700
commitdca510fad6fe0978873c803574d1140bd8a60853 (patch)
treef4b748552b9c18dfbd07469b8c85a8e5d21ab5ba /x11-misc
parentdev-haskell/mtl: mark as bundled with ghc-8.10.5 (diff)
downloadgentoo-dca510fad6fe0978873c803574d1140bd8a60853.tar.gz
gentoo-dca510fad6fe0978873c803574d1140bd8a60853.tar.bz2
gentoo-dca510fad6fe0978873c803574d1140bd8a60853.zip
x11-misc/xwallpaper: add 0.7.2
straight to stable, simple bugfix release Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xwallpaper/Manifest1
-rw-r--r--x11-misc/xwallpaper/xwallpaper-0.7.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/x11-misc/xwallpaper/Manifest b/x11-misc/xwallpaper/Manifest
index 442263380f31..8c5ed5630031 100644
--- a/x11-misc/xwallpaper/Manifest
+++ b/x11-misc/xwallpaper/Manifest
@@ -1,2 +1,3 @@
DIST xwallpaper-0.6.6.tar.xz 85368 BLAKE2B fcb0861d4cecbafc980208b3d2a174b9931a93cd8110b6f2c38eddae19e890295ce5d6d75dc4f09924279a2b0463234f4efdb4dda758ed14ed728abfec6b9bf3 SHA512 e37055b9adfa6950fb423228ff880afaa03dbdf2a7ced6ab1e110dbf4813f68aae3c9147668ebd20665b582bea195470c39b6948cd36879afe54d61c90b6f8d9
DIST xwallpaper-0.7.1.tar.xz 86260 BLAKE2B b8327b15bc421275660cc81d14e4952b37a1310fd50eea61b772115e2c345c01cae9c4f908d9ca55427e642b10bea7277af02e1d3525db6c1d6e80a356db1b2b SHA512 706f814ee892f9d136ef20bb3c9bb4b8537e3ed7029b3b20fbebb1504426529d2fa6a45117a391419253543a48230f5786ffa3f871f85477699c08dfa3ba5c92
+DIST xwallpaper-0.7.2.tar.xz 86212 BLAKE2B 1958ad8eb3f80f2cccdd969230e32986e7d144bf820a4c820a93d0bfdbcaa5512f08eb4014a8b57edb40f1ed55ce54080835c2d2dd46205c399b2ea6adcf1df1 SHA512 2b7166b719edae0d21460682d6c8991739d1a753078920bccb253f905300c694cb6fb12695456be58707d895f8adacd6007023c8e1abd23a0e369e9e80e5106e
diff --git a/x11-misc/xwallpaper/xwallpaper-0.7.2.ebuild b/x11-misc/xwallpaper/xwallpaper-0.7.2.ebuild
new file mode 100644
index 000000000000..2c89348e8c20
--- /dev/null
+++ b/x11-misc/xwallpaper/xwallpaper-0.7.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Wallpaper setting utility for X"
+HOMEPAGE="https://github.com/stoeckmann/xwallpaper"
+
+if [ ${PV} == "9999" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/stoeckmann/${PN}.git"
+else
+ SRC_URI="https://github.com/stoeckmann/${PN}/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="amd64 arm64 ppc64 x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="+jpeg +png seccomp xpm"
+
+RDEPEND="
+ x11-libs/pixman
+ x11-libs/xcb-util
+ x11-libs/xcb-util-image
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ png? ( media-libs/libpng:0= )
+ seccomp? ( >=sys-libs/libseccomp-2.3.1:0= )
+ xpm? ( x11-libs/libXpm )
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ $(use_with jpeg)
+ $(use_with png)
+ $(use_with seccomp)
+ $(use_with xpm)
+ --with-randr
+ )
+ econf "${myconf[@]}"
+}