summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2018-04-26 23:16:23 +1000
committerMichael Palimaka <kensington@gentoo.org>2018-04-26 23:16:31 +1000
commitddb384c3cbc857250e1156e5c190b224c9fbb4e0 (patch)
tree153c04a6b7ea810fe8e146141e858c0c5ce65c24 /x11-misc
parentsys-kernel/gentoo-sources: Linux patch 4.14.37 (diff)
downloadgentoo-ddb384c3cbc857250e1156e5c190b224c9fbb4e0.tar.gz
gentoo-ddb384c3cbc857250e1156e5c190b224c9fbb4e0.tar.bz2
gentoo-ddb384c3cbc857250e1156e5c190b224c9fbb4e0.zip
x11-misc/albert: version bump 0.14.18
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/albert/Manifest2
-rw-r--r--x11-misc/albert/albert-0.14.18.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/x11-misc/albert/Manifest b/x11-misc/albert/Manifest
index 6e357e0a5b55..8f84d28b84aa 100644
--- a/x11-misc/albert/Manifest
+++ b/x11-misc/albert/Manifest
@@ -2,3 +2,5 @@ DIST albert-0.14.15-plugins.tar.gz 540189 BLAKE2B b8243917cdd30c74f26ad852421cf5
DIST albert-0.14.15.tar.gz 84875 BLAKE2B 80e173100a0d135a18b20482ef0eb103634207b1e1a7284b2c5245750bc22478026b25982b714b3fcd079ed7674075a6853917d789f99628a368c6a9c6fd344d SHA512 9a6efd9203f7b96aa14c063a9de8c59e6b4bb0a5c55a64662ec170b75fc71247b7313a1252f71ab2516b4b62538f4c89778a43b8804915996636f49d4e0a6d31
DIST albert-0.14.16-plugins.tar.gz 540297 BLAKE2B e859ff84332fe32ca0513700dd3ee099ef99f240823c70387f630877f972fccf86baab477d0ec5fe166bb979fb6509e9a3ef5e9bb04ba365e789da74d3508555 SHA512 06cefb99ec2da0ccd4ad1f4729cb5626611ba3b226ccae9c8448ad2c58e61790dfd391dcd963524762587b82739f2267aea6b2a2b7affa4c946d6ba438678383
DIST albert-0.14.16.tar.gz 84708 BLAKE2B e901518cf36fd3a68e6b5ddd4f0937ed0cff62f9a8e541b8319670893e2a38c47d222c6e3f25a9673bd1e11ad357382a3441e55497609d049f2b287c97ce6484 SHA512 92708909ed8a91ac2c16ba967c8506a15d4cc74cbb88111761ab18941c3bbab040f5b379b8c780887024b53710b05ad1ce80ffe41bd252358daf80c19b2c953b
+DIST albert-0.14.18-plugins.tar.gz 538138 BLAKE2B baa48198aabf0d5f4ffad46ce9243a733502af93d4b10fab4fd2927524ffe80240859bce2e98316a6ed677474b7fa47cf9255641559ee76d2a760bd32c3cd514 SHA512 c8676b22fa7e6e2ebb8ad12a000402b8e41f710dcb5278f7ad5f87d1319d4eff75a3912870474a2ae153353eba607d579f28c32c6de90b60ee7761071a555c43
+DIST albert-0.14.18.tar.gz 84883 BLAKE2B 706312cc3f29aaf9309c7cddb0f22aec2324560f78ed5a5418f6984e0a037b779d38be3d607c2fe287654b02db4aa125505b0716fc431e7bf679f108fa190555 SHA512 47110ba711b76d5d202a0b42c8442a5a242ca67869094bcb31daa5ca760b05e1b0ccdfbd88d5fdf3d23bb2838e3d4efbaf1a45733ae7612b0941360c2dfe5654
diff --git a/x11-misc/albert/albert-0.14.18.ebuild b/x11-misc/albert/albert-0.14.18.ebuild
new file mode 100644
index 000000000000..8b2d94aa9b36
--- /dev/null
+++ b/x11-misc/albert/albert-0.14.18.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PLUGINS_HASH="ea3a077cc6fa6e5977441e9c49781a6925d068e4"
+inherit cmake-utils gnome2-utils
+
+DESCRIPTION="Desktop agnostic launcher"
+HOMEPAGE="https://albertlauncher.github.io/"
+# plugins is a git submodule. the hash is taken from the submodule reference in the ${PV} tag.
+SRC_URI="https://github.com/albertlauncher/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+https://github.com/albertlauncher/plugins/archive/${PLUGINS_HASH}.tar.gz -> ${P}-plugins.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug"
+
+RDEPEND="
+ dev-cpp/muParser
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+ x11-libs/libXext
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ mv "${WORKDIR}"/plugins-${PLUGINS_HASH}/* "${S}"/plugins/ || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DEBUG=$(usex debug)
+ -DBUILD_PYTHON=OFF #plugin directory is empty causing build failure
+ -DBUILD_VIRTUALBOX=OFF #plugin needs virtualbox installed to build, untested
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}