summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-23 19:32:40 -0700
committerMatt Turner <mattst88@gentoo.org>2022-03-23 19:35:51 -0700
commite16d3cb772f60829a276a7e3d45d8d9af0b0d2b6 (patch)
tree0869d3c48426fba0cc2146045b45f539837b5bf1 /x11-misc
parentapp-shells/nushell: drop 0.41.0, 0.42.0 (diff)
downloadgentoo-e16d3cb772f60829a276a7e3d45d8d9af0b0d2b6.tar.gz
gentoo-e16d3cb772f60829a276a7e3d45d8d9af0b0d2b6.tar.bz2
gentoo-e16d3cb772f60829a276a7e3d45d8d9af0b0d2b6.zip
x11-misc/alacarte: Version bump to 3.44.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/alacarte/Manifest1
-rw-r--r--x11-misc/alacarte/alacarte-3.44.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/x11-misc/alacarte/Manifest b/x11-misc/alacarte/Manifest
index d2e92e9f5620..456e1e7e4dc8 100644
--- a/x11-misc/alacarte/Manifest
+++ b/x11-misc/alacarte/Manifest
@@ -1 +1,2 @@
DIST alacarte-3.42.0.tar.xz 203836 BLAKE2B e020529acd5b6b716c8e1b876b3edc1107cf61fbcebb648ce7f593e830f0ae7ea3445a5ccda2cd798e0441e999cff2e9e4630a7b2fe0b711adef56bf59931c25 SHA512 df56f79e0697268ceebd15614c9e6c6bbef82c10c64c90b39eac1718043edb1a1ea71d03798705d94407cf2dcc3fead6c2d08ff6c5a9ca710574eb15ffed68d1
+DIST alacarte-3.44.1.tar.xz 253364 BLAKE2B ebd542430f909291d06c1094aac52f87760547013f012167fa5616609251a6cb48b258122424a119b3ab10e6e2289d9a282dd66da3dcf5590b09d9c686a8934b SHA512 84b1cebdcbb53e2cca5a1425829b00db0b2a11e308584ea96179c2d0451d8c77fa6a995ae4671a024fab72869c7d2e9986dc310bfab38fe8b7b2f54d383501ca
diff --git a/x11-misc/alacarte/alacarte-3.44.1.ebuild b/x11-misc/alacarte/alacarte-3.44.1.ebuild
new file mode 100644
index 000000000000..c78a03bfd63d
--- /dev/null
+++ b/x11-misc/alacarte/alacarte-3.44.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="xml"
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Simple GNOME menu editor"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/alacarte"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]')
+ >=gnome-base/gnome-menus-3.5.3:3[introspection]
+"
+RDEPEND="${DEPEND}
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/gtk+:3[introspection]
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_install() {
+ gnome2_src_install
+ python_optimize
+}