summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2016-06-18 22:48:01 +0300
committerSergey Popov <pinkbyte@gentoo.org>2016-06-18 22:48:01 +0300
commite3659127f1d87ce2b45161c927857d3a09cb9410 (patch)
tree4793e4e84689b0953442142c99291dfd8f4d3e57 /x11-misc
parentnet-misc/xrdp: Wipe invalid := deps (diff)
downloadgentoo-e3659127f1d87ce2b45161c927857d3a09cb9410.tar.gz
gentoo-e3659127f1d87ce2b45161c927857d3a09cb9410.tar.bz2
gentoo-e3659127f1d87ce2b45161c927857d3a09cb9410.zip
x11-misc/outwiker: version bump
Unstable version, WIP, causes crashes inside wxwidgets stuff Gentoo-Bug: 584170 Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/outwiker/Manifest1
-rw-r--r--x11-misc/outwiker/outwiker-2.0.0.794.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/x11-misc/outwiker/Manifest b/x11-misc/outwiker/Manifest
index 5b366f2829d8..72c15f2d8649 100644
--- a/x11-misc/outwiker/Manifest
+++ b/x11-misc/outwiker/Manifest
@@ -1,2 +1,3 @@
DIST outwiker-1.8.0.tar.gz 27931330 SHA256 b000980b7c744000f1876860c163a27b5c9513ceb04dc77f4fbe974bfdf1a060 SHA512 d4b669383c8c1c95683e8f38617618583076f25db4c3eac778644c9bceeb1e78a7574a1dbea962e2d513e5a0349fced52608a470eb7b6c84dbf83a09c0256df6 WHIRLPOOL 10f0f13188a7da3bf12c15f64b23ba751d74d0fb4757cd3ab4db4d0b64a49177c0cb792f95b6dfc7d716a45b54671ca72c8642d753070e3aa071371a9f5bfea5
DIST outwiker-1.9.0.790.tar.gz 37720668 SHA256 37de06fe66d990ea05e1fa0ee7520ea4ffbcf1a10451ae082e9b1dbf874a7643 SHA512 3916692b307efb1a1c44c87e19cf3e8eb8cdb4cbc07decda637ab5a5ea399ba6f5d2e5c1b4c528bc4238ab66cb8fdf5954fc9a21185f25fbb6e886a5ca1be7c9 WHIRLPOOL ec9ecbc58fb3e6f4dbe3ad8f69486933304a79ba7b639cc81abdca2e0a6ac4dd31805dbcc3a7118e5bfc39f5dcdf15feb93485618104adf572f424a6fd986d50
+DIST outwiker-2.0.0.794.tar.gz 40689962 SHA256 6de40d9307a3ec0f3fb32f7f6039351122c34fa96ebb4b54bda70115bc2c0b1b SHA512 2ecd63af7ba7751028c7da49f298c15478fa2366206a899edd1de0dbe76a5422a0f58e0c455b5bc58738cbcd42a939c8d7c329cdc912b8cec955ad7cca12171e WHIRLPOOL 8253189e9859983d6a3ed82f442d543e035b0368d2be50e0198ba54d598fda0c50eb0243c17f984cad4bd6c6372d4554b027230fa0645d53d88daa28ed5a0ce6
diff --git a/x11-misc/outwiker/outwiker-2.0.0.794.ebuild b/x11-misc/outwiker/outwiker-2.0.0.794.ebuild
new file mode 100644
index 000000000000..6c24160788b1
--- /dev/null
+++ b/x11-misc/outwiker/outwiker-2.0.0.794.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-r1
+
+DESCRIPTION="The tree notes organizer"
+HOMEPAGE="http://jenyay.net/Outwiker/English"
+SRC_URI="https://github.com/Jenyay/${PN}/archive/unstable_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="" # Keywords are dropped, cause this version cause a LOT of crashes
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/wxpython:3.0[${PYTHON_USEDEP}]
+ x11-libs/wxGTK:3.0[webkit]
+ x11-misc/xdg-utils
+ x11-themes/hicolor-icon-theme
+"
+
+S="${WORKDIR}/${PN}-unstable_${PV}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_prepare() {
+ # fix desktop file
+ sed -i -e 's/Application;//' need_for_build/debian_debsource/outwiker.desktop || die 'sed on outwiker.desktop failed'
+
+ eapply_user
+}
+
+src_compile() { :; }
+
+src_install() {
+ # Do not install tests
+ rm -r src/test*
+
+ insinto "/usr/share/${PN}"
+ doins -r src/*
+ dobin "need_for_build/debian_debsource/${PN}"
+
+ domenu "need_for_build/debian_debsource/${PN}.desktop"
+ dodoc README README.md
+
+ # Install mans
+ doman need_for_build/debian_debsource/man/man1/${PN}.1
+ insinto /usr/share/man/ru/man1
+ doins need_for_build/debian_debsource/man/ru/man1/${PN}.1
+
+ # Install icons
+ doicon "images/${PN}.xpm"
+ newicon -s scalable "images/${PN}.svg" "${PN}.svg"
+ for i in 16 22 24 32 48 64 128 256; do
+ newicon -s $i "images/${PN}_$i.png" "${PN}.png"
+ done
+}