summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-01-05 00:39:02 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-01-05 00:39:02 +0100
commite9c0602f16037ba0bac7f93a52340b117dbc3107 (patch)
tree84eb372390ab199c2832b3b29463b5771db008e2 /x11-misc
parentx11-misc/wmctrl: EAPI 6 bump. (diff)
downloadgentoo-e9c0602f16037ba0bac7f93a52340b117dbc3107.tar.gz
gentoo-e9c0602f16037ba0bac7f93a52340b117dbc3107.tar.bz2
gentoo-e9c0602f16037ba0bac7f93a52340b117dbc3107.zip
x11-misc/xwinwrap: EAPI 6 bump.
Package-Manager: portage-2.3.0
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xwinwrap/xwinwrap-0_p4-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-misc/xwinwrap/xwinwrap-0_p4-r1.ebuild b/x11-misc/xwinwrap/xwinwrap-0_p4-r1.ebuild
new file mode 100644
index 000000000000..980a19530937
--- /dev/null
+++ b/x11-misc/xwinwrap/xwinwrap-0_p4-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="replace a desktop background with a movie or screensaver"
+HOMEPAGE="http://tech.shantanugoel.com/projects/linux/shantz-xwinwrap"
+SRC_URI="https://bazaar.launchpad.net/~shantanu-goel/xwinwrap/devel/tarball/4 -> ${P}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ x11-libs/libXext
+ x11-libs/libXrender"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P}/${PN}/devel"
+
+src_unpack() {
+ default
+ mv * ./"${P}" || die
+}
+
+src_compile() {
+ local cmd="$(tc-getCC) -Wall ${CFLAGS} ${PN}.c -o ${PN} ${LDFLAGS} \
+ $(pkg-config --libs x11 xext xrender)"
+ ebegin $cmd
+ $cmd || die
+ eend $?
+}
+
+src_install() {
+ dobin "${PN}"
+}