summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-02-02 10:40:07 +0100
committerJeroen Roovers <jer@gentoo.org>2020-02-02 10:40:39 +0100
commitfad59b3a7142b73175bfaaa6035b6d333da1cfa0 (patch)
tree0e9031663322b0a9804b865eab6a5ab52f0a7016 /x11-misc
parentdev-ruby/ruby-openid: add ruby27, fix examples installation (diff)
downloadgentoo-fad59b3a7142b73175bfaaa6035b6d333da1cfa0.tar.gz
gentoo-fad59b3a7142b73175bfaaa6035b6d333da1cfa0.tar.bz2
gentoo-fad59b3a7142b73175bfaaa6035b6d333da1cfa0.zip
x11-misc/habak: Fix CFLAGS=-fno-common
Package-Manager: Portage-2.3.86, Repoman-2.3.20 Closes: https://bugs.gentoo.org/show_bug.cgi?id=707774 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/habak/files/habak-0.2.5-fno-common.patch33
-rw-r--r--x11-misc/habak/habak-0.2.5-r3.ebuild3
2 files changed, 35 insertions, 1 deletions
diff --git a/x11-misc/habak/files/habak-0.2.5-fno-common.patch b/x11-misc/habak/files/habak-0.2.5-fno-common.patch
new file mode 100644
index 000000000000..0fad5f4df563
--- /dev/null
+++ b/x11-misc/habak/files/habak-0.2.5-fno-common.patch
@@ -0,0 +1,33 @@
+--- a/src/random.c
++++ b/src/random.c
+@@ -8,12 +8,15 @@
+ #include <regex.h>
+
+ #include <errno.h>
++
++#include "i.h"
++
+ extern int errno;
+ int syserr;
+
+ #define ALLOC_STEP 1000
+ regex_t regexp;
+-int size_files=0, used_files=0, i=0;
++int size_files=0, used_files=0;
+ char **files, *wyjscie;
+ regmatch_t matchpos;
+
+--- a/src/habak.c
++++ b/src/habak.c
+@@ -14,6 +14,7 @@
+ #include <Imlib2.h>
+ #include "types.h"
+ #include "proto.h"
++#include "i.h"
+
+ habak_l *current_list_item=NULL, *first_list_item=NULL;
+ habak_t *current_habak;
+--- /dev/null
++++ b/src/i.h
+@@ -0,0 +1 @@
++extern int i;
diff --git a/x11-misc/habak/habak-0.2.5-r3.ebuild b/x11-misc/habak/habak-0.2.5-r3.ebuild
index 1dcc37e3e714..4279398d92db 100644
--- a/x11-misc/habak/habak-0.2.5-r3.ebuild
+++ b/x11-misc/habak/habak-0.2.5-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -23,6 +23,7 @@ DEPEND="
"
DOCS=( ChangeLog README TODO "${FILESDIR}"/README.en )
PATCHES=(
+ "${FILESDIR}"/${P}-fno-common.patch
"${FILESDIR}"/${P}-gentoo.patch
)