summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2016-06-18 19:17:45 +0300
committerSergey Popov <pinkbyte@gentoo.org>2016-06-18 19:19:11 +0300
commitffb13985985338cce61ed7077b03324639ba3768 (patch)
treedd48dfac9b0a039f1129c3088c3302ce6df05784 /x11-misc
parentjava-vm-2.eclass: Remove unused nsplugin code (diff)
downloadgentoo-ffb13985985338cce61ed7077b03324639ba3768.tar.gz
gentoo-ffb13985985338cce61ed7077b03324639ba3768.tar.bz2
gentoo-ffb13985985338cce61ed7077b03324639ba3768.zip
x11-misc/outwiker: version bump
Set SLOT on wxpython dependency Gentoo-Bug: 571488 Gentoo-Bug: 584170 Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/outwiker/Manifest1
-rw-r--r--x11-misc/outwiker/outwiker-1.8.0.ebuild2
-rw-r--r--x11-misc/outwiker/outwiker-1.9.0.790.ebuild63
3 files changed, 65 insertions, 1 deletions
diff --git a/x11-misc/outwiker/Manifest b/x11-misc/outwiker/Manifest
index 2afbb84b7741..5b366f2829d8 100644
--- a/x11-misc/outwiker/Manifest
+++ b/x11-misc/outwiker/Manifest
@@ -1 +1,2 @@
DIST outwiker-1.8.0.tar.gz 27931330 SHA256 b000980b7c744000f1876860c163a27b5c9513ceb04dc77f4fbe974bfdf1a060 SHA512 d4b669383c8c1c95683e8f38617618583076f25db4c3eac778644c9bceeb1e78a7574a1dbea962e2d513e5a0349fced52608a470eb7b6c84dbf83a09c0256df6 WHIRLPOOL 10f0f13188a7da3bf12c15f64b23ba751d74d0fb4757cd3ab4db4d0b64a49177c0cb792f95b6dfc7d716a45b54671ca72c8642d753070e3aa071371a9f5bfea5
+DIST outwiker-1.9.0.790.tar.gz 37720668 SHA256 37de06fe66d990ea05e1fa0ee7520ea4ffbcf1a10451ae082e9b1dbf874a7643 SHA512 3916692b307efb1a1c44c87e19cf3e8eb8cdb4cbc07decda637ab5a5ea399ba6f5d2e5c1b4c528bc4238ab66cb8fdf5954fc9a21185f25fbb6e886a5ca1be7c9 WHIRLPOOL ec9ecbc58fb3e6f4dbe3ad8f69486933304a79ba7b639cc81abdca2e0a6ac4dd31805dbcc3a7118e5bfc39f5dcdf15feb93485618104adf572f424a6fd986d50
diff --git a/x11-misc/outwiker/outwiker-1.8.0.ebuild b/x11-misc/outwiker/outwiker-1.8.0.ebuild
index 013cb1c906f8..9a37a5d33798 100644
--- a/x11-misc/outwiker/outwiker-1.8.0.ebuild
+++ b/x11-misc/outwiker/outwiker-1.8.0.ebuild
@@ -17,7 +17,7 @@ KEYWORDS="~amd64 ~x86"
DEPEND="${PYTHON_DEPS}"
RDEPEND="${DEPEND}
dev-python/pywebkitgtk[${PYTHON_USEDEP}]
- dev-python/wxpython[${PYTHON_USEDEP}]
+ dev-python/wxpython:2.8[${PYTHON_USEDEP}]
dev-python/pillow[${PYTHON_USEDEP}]
x11-misc/xdg-utils
x11-themes/hicolor-icon-theme
diff --git a/x11-misc/outwiker/outwiker-1.9.0.790.ebuild b/x11-misc/outwiker/outwiker-1.9.0.790.ebuild
new file mode 100644
index 000000000000..c9cba69733cb
--- /dev/null
+++ b/x11-misc/outwiker/outwiker-1.9.0.790.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-r1
+
+DESCRIPTION="The tree notes organizer"
+HOMEPAGE="http://jenyay.net/Outwiker/English"
+SRC_URI="https://github.com/Jenyay/${PN}/archive/release_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pywebkitgtk[${PYTHON_USEDEP}]
+ dev-python/wxpython:2.8[${PYTHON_USEDEP}]
+ x11-misc/xdg-utils
+ x11-themes/hicolor-icon-theme
+"
+
+S="${WORKDIR}/${PN}-release_${PV}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_prepare() {
+ # fix desktop file
+ sed -i -e 's/Application;//' outwiker.desktop || die 'sed on outwiker.desktop failed'
+
+ eapply_user
+}
+
+src_compile() { :; }
+
+src_install() {
+ # Do not install tests
+ rm -r src/test*
+
+ insinto "/usr/share/${PN}"
+ doins -r src/*
+ dobin "${PN}"
+
+ domenu "${PN}.desktop"
+ dodoc README README.md
+
+ # Install mans
+ doman man/man1/${PN}.1
+ insinto /usr/share/man/ru/man1
+ doins man/ru/man1/${PN}.1
+
+ # Install icons
+ doicon "images/${PN}.xpm"
+ newicon -s scalable "images/${PN}.svg" "${PN}.svg"
+ for i in 16 22 24 32 48 64 128 256; do
+ newicon -s $i "images/${PN}_$i.png" "${PN}.png"
+ done
+}