summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-08-12 16:13:36 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-08-12 16:13:56 -0400
commit51cd181c27f95e0680b8d9843e62c6f7bb83497d (patch)
tree5c4acba4498839ceb9232db08895e769de4764d9 /x11-plugins/ascpu
parentmedia-sound/spotify: bup (diff)
downloadgentoo-51cd181c27f95e0680b8d9843e62c6f7bb83497d.tar.gz
gentoo-51cd181c27f95e0680b8d9843e62c6f7bb83497d.tar.bz2
gentoo-51cd181c27f95e0680b8d9843e62c6f7bb83497d.zip
x11-plugins/ascpu: new revision that respects LDFLAGS.
This revision updates to EAPI=6 and cleans up the ebuild a bit. It contains a notable improvement, Michael Mair-Keimberger's patch to append LDFLAGS to the link command. Gentoo-Bug: 337915 Package-Manager: portage-2.2.28
Diffstat (limited to 'x11-plugins/ascpu')
-rw-r--r--x11-plugins/ascpu/ascpu-1.11-r1.ebuild40
-rw-r--r--x11-plugins/ascpu/files/ascpu-1.11-gentoo-r1.patch46
2 files changed, 86 insertions, 0 deletions
diff --git a/x11-plugins/ascpu/ascpu-1.11-r1.ebuild b/x11-plugins/ascpu/ascpu-1.11-r1.ebuild
new file mode 100644
index 000000000000..f6113fd41183
--- /dev/null
+++ b/x11-plugins/ascpu/ascpu-1.11-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="CPU statistics monitor utility for X Windows"
+SRC_URI="http://www.tigr.net/afterstep/download/ascpu/${P}.tar.gz"
+HOMEPAGE="http://www.tigr.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="jpeg"
+
+RDEPEND="x11-libs/libXpm
+ x11-libs/libSM
+ jpeg? ( virtual/jpeg:0 )"
+
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+PATCHES=( "${FILESDIR}/${P}-gentoo-r1.patch" )
+
+src_configure() {
+ econf $(use_enable jpeg)
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/man/man1
+ dodoc README
+ default
+}
diff --git a/x11-plugins/ascpu/files/ascpu-1.11-gentoo-r1.patch b/x11-plugins/ascpu/files/ascpu-1.11-gentoo-r1.patch
new file mode 100644
index 000000000000..868c1d53b96a
--- /dev/null
+++ b/x11-plugins/ascpu/files/ascpu-1.11-gentoo-r1.patch
@@ -0,0 +1,46 @@
+--- a/autoconf/Makefile.common.in 1999-05-06 23:35:32.000000000 +0200
++++ b/autoconf/Makefile.common.in 2006-09-11 23:07:41.000000000 +0200
+@@ -9,11 +9,10 @@
+ install: install.bin install.man
+
+ install.bin: $(PROG)
+- $(STRIP) $(PROG)
+- $(INSTALL_PROGRAM) $(PROG) $(AFTER_BIN_DIR)
++ $(INSTALL_PROGRAM) $(PROG) $(DESTDIR)$(AFTER_BIN_DIR)
+
+ install.man:
+- $(INSTALL_DATA) $(PROG).man $(AFTER_MAN_DIR)/$(PROG).1x
++ $(INSTALL_DATA) $(PROG).man $(DESTDIR)$(AFTER_MAN_DIR)/$(PROG).1x
+
+ uninstall:
+ $(RMF) $(AFTER_BIN_DIR)/$(PROG)
+--- a/autoconf/Makefile.defines.in 1999-05-06 23:35:32.000000000 +0200
++++ b/autoconf/Makefile.defines.in 2006-09-11 23:17:40.000000000 +0200
+@@ -2,6 +2,7 @@
+ # Copyright (c) 1998, Guylhem AZNAR <guylhem@oeil.qc.ca>
+ #
+
++DESTDIR =
+ CC = @CC@
+ CCFLAGS = @CFLAGS@
+ # -march=pentiumpro -mcpu=pentiumpro
+@@ -21,7 +22,7 @@
+ LEXFLAGS =
+
+ INSTALL = @INSTALL@
+-INSTALL_PROGRAM = @INSTALL@ -s -m 755
++INSTALL_PROGRAM = @INSTALL@ -m 755
+ INSTALL_DATA = @INSTALL@ -m 644
+
+ INCS_X = @X_CFLAGS@
+--- a/autoconf/Makefile.common.in 1999-05-06 23:35:32.000000000 +0200
++++ b/autoconf/Makefile.common.in 2013-03-18 18:13:05.550047149 +0100
+@@ -34,7 +34,7 @@
+ done
+
+ $(PROG): $(OBJS)
+- $(CC) $(OBJS) $(LIBRARIES) $(EXTRA_LIBRARIES) -o $(@)
++ $(CC) $(OBJS) $(LIBRARIES) $(EXTRA_LIBRARIES) -o $(@) $(LDFLAGS)
+
+ .c.o:
+ $(CC) $(CCFLAGS) $(EXTRA_DEFINES) $(INCLUDES) $(EXTRA_INCLUDES) -c $*.c