summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/ascpu
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/ascpu')
-rw-r--r--x11-plugins/ascpu/Manifest1
-rw-r--r--x11-plugins/ascpu/ascpu-1.11.ebuild40
-rw-r--r--x11-plugins/ascpu/files/ascpu-1.11-gentoo.patch36
-rw-r--r--x11-plugins/ascpu/metadata.xml5
4 files changed, 82 insertions, 0 deletions
diff --git a/x11-plugins/ascpu/Manifest b/x11-plugins/ascpu/Manifest
new file mode 100644
index 000000000000..829a05c9b9a7
--- /dev/null
+++ b/x11-plugins/ascpu/Manifest
@@ -0,0 +1 @@
+DIST ascpu-1.11.tar.gz 43867 SHA256 fdd2ee8a6cd006bbb2d6d1871b92c33b18f7bd5e1ab8a367572e4b4f1f53c0a2
diff --git a/x11-plugins/ascpu/ascpu-1.11.ebuild b/x11-plugins/ascpu/ascpu-1.11.ebuild
new file mode 100644
index 000000000000..9f1de6244479
--- /dev/null
+++ b/x11-plugins/ascpu/ascpu-1.11.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+IUSE="jpeg"
+DESCRIPTION="CPU statistics monitor utility for X Windows"
+SRC_URI="http://www.tigr.net/afterstep/download/ascpu/${P}.tar.gz"
+HOMEPAGE="http://www.tigr.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ~mips ppc ppc64 sparc x86"
+
+RDEPEND="x11-libs/libXpm
+ x11-libs/libSM
+ jpeg? ( virtual/jpeg )"
+
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ econf $(use_enable jpeg) || die "econf failed"
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/man/man1
+
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README
+}
diff --git a/x11-plugins/ascpu/files/ascpu-1.11-gentoo.patch b/x11-plugins/ascpu/files/ascpu-1.11-gentoo.patch
new file mode 100644
index 000000000000..b26374a4ac03
--- /dev/null
+++ b/x11-plugins/ascpu/files/ascpu-1.11-gentoo.patch
@@ -0,0 +1,36 @@
+--- autoconf/Makefile.common.in.orig 1999-05-06 23:35:32.000000000 +0200
++++ autoconf/Makefile.common.in 2006-09-11 23:07:41.000000000 +0200
+@@ -9,11 +9,10 @@
+ install: install.bin install.man
+
+ install.bin: $(PROG)
+- $(STRIP) $(PROG)
+- $(INSTALL_PROGRAM) $(PROG) $(AFTER_BIN_DIR)
++ $(INSTALL_PROGRAM) $(PROG) $(DESTDIR)$(AFTER_BIN_DIR)
+
+ install.man:
+- $(INSTALL_DATA) $(PROG).man $(AFTER_MAN_DIR)/$(PROG).1x
++ $(INSTALL_DATA) $(PROG).man $(DESTDIR)$(AFTER_MAN_DIR)/$(PROG).1x
+
+ uninstall:
+ $(RMF) $(AFTER_BIN_DIR)/$(PROG)
+--- autoconf/Makefile.defines.in.orig 1999-05-06 23:35:32.000000000 +0200
++++ autoconf/Makefile.defines.in 2006-09-11 23:17:40.000000000 +0200
+@@ -2,6 +2,7 @@
+ # Copyright (c) 1998, Guylhem AZNAR <guylhem@oeil.qc.ca>
+ #
+
++DESTDIR =
+ CC = @CC@
+ CCFLAGS = @CFLAGS@
+ # -march=pentiumpro -mcpu=pentiumpro
+@@ -21,7 +22,7 @@
+ LEXFLAGS =
+
+ INSTALL = @INSTALL@
+-INSTALL_PROGRAM = @INSTALL@ -s -m 755
++INSTALL_PROGRAM = @INSTALL@ -m 755
+ INSTALL_DATA = @INSTALL@ -m 644
+
+ INCS_X = @X_CFLAGS@
+
diff --git a/x11-plugins/ascpu/metadata.xml b/x11-plugins/ascpu/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/x11-plugins/ascpu/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>