summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/asmon/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/asmon/files')
-rw-r--r--x11-plugins/asmon/files/asmon-0.7.cflags.diff31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-plugins/asmon/files/asmon-0.7.cflags.diff b/x11-plugins/asmon/files/asmon-0.7.cflags.diff
new file mode 100644
index 000000000000..b69c692abb90
--- /dev/null
+++ b/x11-plugins/asmon/files/asmon-0.7.cflags.diff
@@ -0,0 +1,31 @@
+--- asmon/Makefile.orig 1999-06-26 03:35:13.000000000 +0200
++++ asmon/Makefile 2006-08-24 20:21:52.000000000 +0200
+@@ -4,7 +4,7 @@
+ #SOLARIS_LIBS = -lsocket -lkstat
+ #SOLARIS_OBJS = solaris26.o
+
+-LIBDIR = -L/usr/X11R6/lib
++LIBDIR = -L/usr/lib
+ LIBS = -lXpm -lXext -lX11 $(SOLARIS_LIBS)
+ OBJS = asmon.o $(SOLARIS_OBJS) \
+ ../wmgeneral/wmgeneral.o \
+@@ -12,16 +12,16 @@
+ ../wmgeneral/list.o
+
+ .c.o:
+- gcc -c -Wall $(SOLARIS) $< -o $*.o
++ gcc -c -Wall $(CFLAGS) $(SOLARIS) $< -o $*.o
+
+ asmon: $(OBJS)
+ gcc -o asmon $(OBJS) $(LIBDIR) $(LIBS)
+
+ clean::
+ for i in $(OBJS) ; do \
+- rm $$i;\
++ rm -f $$i;\
+ done
+- rm asmon
++ rm -f asmon
+
+ install::
+ cp -f asmon /usr/local/bin