summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/desklet-ImageSlideShow
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/desklet-ImageSlideShow')
-rw-r--r--x11-plugins/desklet-ImageSlideShow/Manifest1
-rw-r--r--x11-plugins/desklet-ImageSlideShow/desklet-ImageSlideShow-0.8-r1.ebuild21
-rw-r--r--x11-plugins/desklet-ImageSlideShow/files/ImageSlideShow-0.8-cache-dir.patch27
-rw-r--r--x11-plugins/desklet-ImageSlideShow/metadata.xml16
4 files changed, 65 insertions, 0 deletions
diff --git a/x11-plugins/desklet-ImageSlideShow/Manifest b/x11-plugins/desklet-ImageSlideShow/Manifest
new file mode 100644
index 000000000000..19705745d902
--- /dev/null
+++ b/x11-plugins/desklet-ImageSlideShow/Manifest
@@ -0,0 +1 @@
+DIST ImageSlideShow-0.8.tar.gz 25187 SHA256 60762ee089174494e97ca3cc97e03d2287971ddb877ad0143d82133661fad32b SHA512 0920ceca7555776a54b6f456b6af8be38da22fde345766b8e48b0771330635025ae3c0a19748ff0be1db9bc5ffa887fbd9cd7d9f79dc1fa51ad62842408986cb WHIRLPOOL a362c5039aa26b0499d892f6ffea82f1075adda162eb1bf97f325a8f70f50a4c3bb7884434076fb4b874428189cb7eed88b33387a94cbee071ff641d0fe16f1f
diff --git a/x11-plugins/desklet-ImageSlideShow/desklet-ImageSlideShow-0.8-r1.ebuild b/x11-plugins/desklet-ImageSlideShow/desklet-ImageSlideShow-0.8-r1.ebuild
new file mode 100644
index 000000000000..9ca2ae0d7f3e
--- /dev/null
+++ b/x11-plugins/desklet-ImageSlideShow/desklet-ImageSlideShow-0.8-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+CONTROL_NAME="${PN#desklet-}"
+
+inherit gdesklets
+
+DESCRIPTION="ImageSlideShow Control for gDesklets"
+HOMEPAGE="http://gdesklets.de/index.php?q=control/view/211"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="${RDEPEND} virtual/python-imaging"
+DOCS="MANIFEST README"
+
+src_prepare() {
+ epatch "${FILESDIR}/${CONTROL_NAME}-${PV}-cache-dir.patch"
+}
diff --git a/x11-plugins/desklet-ImageSlideShow/files/ImageSlideShow-0.8-cache-dir.patch b/x11-plugins/desklet-ImageSlideShow/files/ImageSlideShow-0.8-cache-dir.patch
new file mode 100644
index 000000000000..64bcd08422b9
--- /dev/null
+++ b/x11-plugins/desklet-ImageSlideShow/files/ImageSlideShow-0.8-cache-dir.patch
@@ -0,0 +1,27 @@
+--- ImageSlideShow/__init__.py.orig 2008-01-15 16:36:23.000000000 +0100
++++ ImageSlideShow/__init__.py 2009-05-10 16:57:27.000000000 +0200
+@@ -45,11 +45,10 @@
+ self.__previous_width = 300
+
+ #Cache folder
+- #folder = os.path.expanduser("~") + "/" + ".cache2/imageslideshow"
+- folder = "/tmp/imageslideshow"
++ folder = os.path.expanduser("~") + "/" + ".thumbnails/imageslideshow"
+ debugger("cache folder is:" + folder)
+ if not os.path.isdir(folder):
+- os.mkdir(folder)
++ os.makedirs(folder)
+
+ self.__thumbnail_folder=folder
+
+--- ImageSlideShow/directorywalk.py.orig 2009-05-02 20:42:41.000000000 +0200
++++ ImageSlideShow/directorywalk.py 2009-05-28 18:57:51.000000000 +0200
+@@ -10,7 +10,7 @@
+ st = os.lstat(os.path.join(top, name))
+ except os.error:
+ continue
+- if stat.S_ISDIR(st.st_mode):
++ if stat.S_ISDIR(st.st_mode) or stat.S_ISLNK(st.st_mode):
+ for (newtop, children) in walktree (os.path.join(top, name), depthfirst):
+ yield newtop, children
+ if depthfirst:
diff --git a/x11-plugins/desklet-ImageSlideShow/metadata.xml b/x11-plugins/desklet-ImageSlideShow/metadata.xml
new file mode 100644
index 000000000000..687d5ef03089
--- /dev/null
+++ b/x11-plugins/desklet-ImageSlideShow/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+ <longdescription lang="en">
+ A Control for gDesklets (gnome-extra/gdesklets-core). Provides
+ functions to control an image slideshow and read select image
+ meta-data. Requires the Python Imaging Library.
+ </longdescription>
+ <upstream>
+ <maintainer>
+ <email>shizeon-at-gmail-dot-com</email>
+ </maintainer>
+ </upstream>
+</pkgmetadata>
+