summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2017-11-28 15:39:53 -0500
committerIan Stakenvicius <axs@gentoo.org>2017-11-29 12:44:26 -0500
commit597eb16e27b4e1349cbbaf5f65cc8bb4c655057e (patch)
treecaeea3cf551ce7e82768165776586cf3efa17410 /x11-plugins/enigmail/enigmail-9999.ebuild
parentdev-php/xdebug: Mark stable on amd64 wrt bug 633618 (diff)
downloadgentoo-597eb16e27b4e1349cbbaf5f65cc8bb4c655057e.tar.gz
gentoo-597eb16e27b4e1349cbbaf5f65cc8bb4c655057e.tar.bz2
gentoo-597eb16e27b4e1349cbbaf5f65cc8bb4c655057e.zip
x11-plugins/enigmail: install extension so that it will be dynamically loaded
Instead of installing files in a generic location that then requires compile-time support from thunderbird or seamonkey to integrate, starting with v1.9.8.3-r1 enigmail now installs in a path that relevant mozilla products will load from on startup. This means that USE=crypt on seamonkey and thunderbird will be going away, as the installation of enigmail now only requires adding this package to @world. Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'x11-plugins/enigmail/enigmail-9999.ebuild')
-rw-r--r--x11-plugins/enigmail/enigmail-9999.ebuild19
1 files changed, 17 insertions, 2 deletions
diff --git a/x11-plugins/enigmail/enigmail-9999.ebuild b/x11-plugins/enigmail/enigmail-9999.ebuild
index edffcc2deb93..ec95bc9fb44a 100644
--- a/x11-plugins/enigmail/enigmail-9999.ebuild
+++ b/x11-plugins/enigmail/enigmail-9999.ebuild
@@ -44,8 +44,18 @@ src_compile() {
}
src_install() {
- insinto /usr/share/${PN}
- doins -r build/dist/{chrome,components,defaults,modules,wrappers,chrome.manifest,install.rdf}
+ local emid=$(sed -n '/<em:id>/!d; s/.*\({.*}\).*/\1/; p; q' build/dist/install.rdf)
+ [[ -n ${emid} ]] || die "Could not scrape EM:ID from install.rdf"
+
+ mv build/enigmail*.xpi build/"${emid}.xpi" || die 'Could not rename XPI to match EM:ID'
+
+ # thunderbird
+ insinto "/usr/share/mozilla/extensions/{3550f703-e582-4d05-9a08-453d09bdfdc6}"
+ doins build/"${emid}.xpi"
+
+ # seamonkey
+ insinto "/usr/share/mozilla/extensions/{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}"
+ doins build/"${emid}.xpi"
}
pkg_postinst() {
@@ -57,4 +67,9 @@ pkg_postinst() {
ewarn "Please use 'eselect pinentry' to select either the gtk or qt front-end"
;;
esac
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "Please restart thunderbird and/or seamonkey in order for them to use"
+ elog "the newly installed version of enigmail."
+ fi
}