summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-10-04 19:28:00 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-10-04 19:30:21 +0200
commitd8d984f9b7ae1acb54b709483281f06bbf78f9c8 (patch)
treee6632534daf3ee512f6f2b28318ecc1a78150da8 /x11-plugins/enigmail/enigmail-9999.ebuild
parentmail-client/thunderbird: add soft blocker on <x11-plugins/enigmail-2.2 (diff)
downloadgentoo-d8d984f9b7ae1acb54b709483281f06bbf78f9c8.tar.gz
gentoo-d8d984f9b7ae1acb54b709483281f06bbf78f9c8.tar.bz2
gentoo-d8d984f9b7ae1acb54b709483281f06bbf78f9c8.zip
x11-plugins/enigmail: bump to v2.2.4
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'x11-plugins/enigmail/enigmail-9999.ebuild')
-rw-r--r--x11-plugins/enigmail/enigmail-9999.ebuild30
1 files changed, 12 insertions, 18 deletions
diff --git a/x11-plugins/enigmail/enigmail-9999.ebuild b/x11-plugins/enigmail/enigmail-9999.ebuild
index 7369918278b0..b990489fba08 100644
--- a/x11-plugins/enigmail/enigmail-9999.ebuild
+++ b/x11-plugins/enigmail/enigmail-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
inherit python-any-r1
@@ -33,7 +33,7 @@ RDEPEND="
app-crypt/pinentry[qt5(-)]
)
)
- !<mail-client/thunderbird-52.5.0
+ !<mail-client/thunderbird-78
"
DEPEND="${RDEPEND}
${PYTHON_DEPS}
@@ -41,30 +41,24 @@ DEPEND="${RDEPEND}
dev-lang/perl
"
-PATCHES=( "${FILESDIR}"/enigmail-no_pEp_auto_download.patch )
+PATCHES=( "${FILESDIR}/enigmail-no_pEp_auto_download.patch" )
-src_compile() {
- # Required or parallel make fails
- emake -C stdlib createlib
-
- emake ipc public ui package lang stdlib
- emake xpi
+src_prepare() {
+ default
+ export MAKEOPTS=-j1
}
src_install() {
- local emid=$(sed -n '/"id":/!d; s/.*\({.*}\).*/\1/; p; q' build/dist/manifest.json)
+ local build_dir=build-tb
+ local emid=$(sed -n '/"id":/!d; s/.*\({.*}\).*/\1/; p; q' ${build_dir}/dist/manifest.json)
[[ -n ${emid} ]] || die "Could not scrape EM:ID from install.rdf"
- mv build/enigmail*.xpi build/"${emid}.xpi" || die 'Could not rename XPI to match EM:ID'
+ mv ${build_dir}/enigmail*.xpi ${build_dir}/"${emid}.xpi" || die 'Could not rename XPI to match EM:ID'
# thunderbird
insinto "/usr/share/mozilla/extensions/{3550f703-e582-4d05-9a08-453d09bdfdc6}"
- doins build/"${emid}.xpi"
-
- # seamonkey
- insinto "/usr/share/mozilla/extensions/{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}"
- doins build/"${emid}.xpi"
+ doins ${build_dir}/"${emid}.xpi"
}
pkg_postinst() {
@@ -78,7 +72,7 @@ pkg_postinst() {
esac
if [[ -n ${REPLACING_VERSIONS} ]]; then
elog
- elog "Please restart thunderbird and/or seamonkey in order for them to use"
+ elog "Please restart thunderbird in order for them to use"
elog "the newly installed version of enigmail."
fi
}