summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-07-16 12:12:20 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-07-16 12:13:14 +0200
commitad7e2c5488de5294b9cf5a02c5d096a2a988c245 (patch)
tree8128ac637e122576af0035ad8a05adf21927677d /x11-plugins/enigmail
parentx11-plugins/enigmail: Bump to version 2.1 (diff)
downloadgentoo-ad7e2c5488de5294b9cf5a02c5d096a2a988c245.tar.gz
gentoo-ad7e2c5488de5294b9cf5a02c5d096a2a988c245.tar.bz2
gentoo-ad7e2c5488de5294b9cf5a02c5d096a2a988c245.zip
x11-plugins/enigmail: Synced live ebuild
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'x11-plugins/enigmail')
-rw-r--r--x11-plugins/enigmail/enigmail-9999.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/x11-plugins/enigmail/enigmail-9999.ebuild b/x11-plugins/enigmail/enigmail-9999.ebuild
index 752b1acb8637..d2c798ea5030 100644
--- a/x11-plugins/enigmail/enigmail-9999.ebuild
+++ b/x11-plugins/enigmail/enigmail-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -44,14 +44,19 @@ DEPEND="${RDEPEND}
dev-lang/perl
"
+PATCHES=( "${FILESDIR}"/enigmail-no_pEp_auto_download.patch )
+
src_compile() {
+ # Required or parallel make fails
+ emake -C stdlib createlib
+
emake ipc public ui package lang stdlib
emake xpi
}
src_install() {
- local emid=$(sed -n '/<em:id>/!d; s/.*\({.*}\).*/\1/; p; q' build/dist/install.rdf)
+ local emid=$(sed -n '/"id":/!d; s/.*\({.*}\).*/\1/; p; q' build/dist/manifest.json)
[[ -n ${emid} ]] || die "Could not scrape EM:ID from install.rdf"
mv build/enigmail*.xpi build/"${emid}.xpi" || die 'Could not rename XPI to match EM:ID'