summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-08-26 08:56:23 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-08-26 08:56:23 -0400
commitaaa3c4fb5ccab0619199d091a8bbf6b323a443ad (patch)
tree602090db8a0d4ee1f91531333040452e09d5e47a /x11-plugins/gkrellfire/gkrellfire-0.4.2-r1.ebuild
parentwww-apache/mod_perl: x86 stable, bug #548932 (diff)
downloadgentoo-aaa3c4fb5ccab0619199d091a8bbf6b323a443ad.tar.gz
gentoo-aaa3c4fb5ccab0619199d091a8bbf6b323a443ad.tar.bz2
gentoo-aaa3c4fb5ccab0619199d091a8bbf6b323a443ad.zip
x11-plugins/gkrellfire: new revision fixing CC and *FLAGS handling.
This new revision updates the ebuild to EAPI=6, and adds a patch that rewrites the Makefile. The inspiration for the patch, and the new ebuild itself were submitted by user Michael Mair-Keimberger. In addition to fixing the CC, CFLAGS, and LDFLAGS handling, the new ebuild adds a USE dependency on app-admin/gkrellm[X], which, in the old EAPI, had to crash the eclass. Gentoo-Bug: 335033 Package-Manager: portage-2.2.28
Diffstat (limited to 'x11-plugins/gkrellfire/gkrellfire-0.4.2-r1.ebuild')
-rw-r--r--x11-plugins/gkrellfire/gkrellfire-0.4.2-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11-plugins/gkrellfire/gkrellfire-0.4.2-r1.ebuild b/x11-plugins/gkrellfire/gkrellfire-0.4.2-r1.ebuild
new file mode 100644
index 000000000000..a05889e8c0d4
--- /dev/null
+++ b/x11-plugins/gkrellfire/gkrellfire-0.4.2-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="CPU load flames for GKrellM 2"
+HOMEPAGE="http://people.freenet.de/thomas-steinke"
+SRC_URI="ftp://ftp.freebsd.org/pub/FreeBSD/ports/distfiles/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-admin/gkrellm[X]"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/fix-CC-CFLAGS-LDFLAGS-handling.patch" )
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}