summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bracht Laumann Jespersen <t@laumann.xyz>2022-03-26 16:00:19 +0100
committerSam James <sam@gentoo.org>2022-04-21 20:54:34 +0100
commit8e5f9cf044af35d05b8a6f4e68efe05d4acd2c37 (patch)
tree59f578a4cc1a59c4302d1be8371f1d3ca49e5046 /x11-plugins/gkrellkam
parentx11-plugins/gkrellm-vaiobright: update EAPI 6 -> 8 (diff)
downloadgentoo-8e5f9cf044af35d05b8a6f4e68efe05d4acd2c37.tar.gz
gentoo-8e5f9cf044af35d05b8a6f4e68efe05d4acd2c37.tar.bz2
gentoo-8e5f9cf044af35d05b8a6f4e68efe05d4acd2c37.zip
x11-plugins/gkrellkam: update EAPI 6 -> 8
Signed-off-by: Thomas Bracht Laumann Jespersen <t@laumann.xyz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-plugins/gkrellkam')
-rw-r--r--x11-plugins/gkrellkam/files/gkrellkam-2.0.0-r1-pkgconfig.patch13
-rw-r--r--x11-plugins/gkrellkam/gkrellkam-2.0.0-r1.ebuild40
2 files changed, 53 insertions, 0 deletions
diff --git a/x11-plugins/gkrellkam/files/gkrellkam-2.0.0-r1-pkgconfig.patch b/x11-plugins/gkrellkam/files/gkrellkam-2.0.0-r1-pkgconfig.patch
new file mode 100644
index 000000000000..c5993890fe6e
--- /dev/null
+++ b/x11-plugins/gkrellkam/files/gkrellkam-2.0.0-r1-pkgconfig.patch
@@ -0,0 +1,13 @@
+--- a/Makefile
++++ b/Makefile
+@@ -12,8 +12,9 @@ DESTDIR =
+ # This should point to the GKrellM headers
+ GKRELLM_HDRS = /usr/include
+
++PKG_CONFIG ?= pkg-config
+ CC = $(CC)
+-GTKFLAGS := $(shell pkg-config gtk+-2.0 --cflags)
++GTKFLAGS := $(shell ${PKG_CONFIG} gtk+-2.0 --cflags)
+ CFLAGS := $(CFLAGS) -fPIC $(GTKFLAGS) -I$(GKRELLM_HDRS)
+ LFLAGS = -shared
+ INST_DIR := $(DESTDIR)/usr/lib/gkrellm2/plugins
diff --git a/x11-plugins/gkrellkam/gkrellkam-2.0.0-r1.ebuild b/x11-plugins/gkrellkam/gkrellkam-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..951eb4818034
--- /dev/null
+++ b/x11-plugins/gkrellkam/gkrellkam-2.0.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gkrellm-plugin toolchain-funcs
+
+MY_P=${P/-/_}
+
+DESCRIPTION="an Image-Watcher-Plugin for GKrellM2"
+HOMEPAGE="http://gkrellkam.sourceforge.net"
+SRC_URI="mirror://sourceforge/gkrellkam/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="
+ app-admin/gkrellm:2[X]
+ net-misc/wget"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-r1-pkgconfig.patch
+)
+
+src_compile() {
+ tc-export PKG_CONFIG
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ local PLUGIN_SO=( ${PN}2$(get_modname) )
+ local PLUGIN_DOCS=( example.list )
+
+ gkrellm-plugin_src_install
+ doman gkrellkam-list.5
+}