summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-08-25 14:33:41 +0200
committerPacho Ramos <pacho@gentoo.org>2016-08-25 14:53:49 +0200
commit81b74aa034caf8df7c29bd03cbee1fb07b87b10f (patch)
tree32562338269d09b02503850b1c869022d61b4215 /x11-plugins/gkrellm-trayicons
parentnet-misc/sstp-client: revision bump (diff)
downloadgentoo-81b74aa034caf8df7c29bd03cbee1fb07b87b10f.tar.gz
gentoo-81b74aa034caf8df7c29bd03cbee1fb07b87b10f.tar.bz2
gentoo-81b74aa034caf8df7c29bd03cbee1fb07b87b10f.zip
x11-plugins/gkrellm-trayicons: Respect LDFLAGS (#338784 by Michael Mair-Keimberger (iamnr3))
Package-Manager: portage-2.3.0
Diffstat (limited to 'x11-plugins/gkrellm-trayicons')
-rw-r--r--x11-plugins/gkrellm-trayicons/files/gkrellm-trayicons-1.03-ldflags.patch25
-rw-r--r--x11-plugins/gkrellm-trayicons/gkrellm-trayicons-1.03.ebuild15
2 files changed, 36 insertions, 4 deletions
diff --git a/x11-plugins/gkrellm-trayicons/files/gkrellm-trayicons-1.03-ldflags.patch b/x11-plugins/gkrellm-trayicons/files/gkrellm-trayicons-1.03-ldflags.patch
new file mode 100644
index 000000000000..92764a9b32af
--- /dev/null
+++ b/x11-plugins/gkrellm-trayicons/files/gkrellm-trayicons-1.03-ldflags.patch
@@ -0,0 +1,25 @@
+--- a/Makefile 2003-11-26 00:27:29.000000000 +0100
++++ b/Makefile_new 2013-03-15 21:36:05.331857288 +0100
+@@ -6,19 +6,18 @@
+ GKRELLM_INCLUDE = -I$(PREFIX)/include
+ GTK_CFLAGS = `$(GTK_CONFIG) --cflags`
+ GTK_LIB = `$(GTK_CONFIG) --libs`
+-FLAGS = -Wall -fPIC $(GTK_CFLAGS) $(GKRELLM_INCLUDE)
+-CFLAGS ?= -O -g
++FLAGS = -fPIC $(GTK_CFLAGS) $(GKRELLM_INCLUDE)
+ CFLAGS += $(FLAGS)
+ CFLAGS += -DVERSION=\"$(VERSION)\"
+ LIBS = $(GTK_LIB)
+ LFLAGS = -shared
+-CC ?= gcc
++CC = $(CC)
+ INSTALL = install -c
+ INSTALL_PROGRAM = $(INSTALL) -s
+ OBJS = trayicons.o
+
+ trayicons.so: $(OBJS)
+- $(CC) $(FLAGS) $(OBJS) -o trayicons.so $(LIBS) $(LFLAGS)
++ $(CC) $(FLAGS) $(LDFLAGS) $(OBJS) -o trayicons.so $(LIBS) $(LFLAGS)
+
+ clean:
+ rm -f *.o core *.so* *.bak *~
diff --git a/x11-plugins/gkrellm-trayicons/gkrellm-trayicons-1.03.ebuild b/x11-plugins/gkrellm-trayicons/gkrellm-trayicons-1.03.ebuild
index 16dd06672109..2d1437b0734f 100644
--- a/x11-plugins/gkrellm-trayicons/gkrellm-trayicons-1.03.ebuild
+++ b/x11-plugins/gkrellm-trayicons/gkrellm-trayicons-1.03.ebuild
@@ -1,16 +1,23 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-inherit gkrellm-plugin
+EAPI=6
+inherit gkrellm-plugin toolchain-funcs
DESCRIPTION="Configurable Tray Icons for GKrellM"
-HOMEPAGE="http://tripie.sweb.cz/gkrellm/trayicons/"
-SRC_URI="http://tripie.sweb.cz/gkrellm/trayicons/dist/${P}.tar.gz"
+HOMEPAGE="http://gkrellm.srcbox.net/Plugins.html"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
IUSE=""
+PATCHES=( "${FILESDIR}"/${P}-ldflags.patch )
+
PLUGIN_SO=trayicons.so
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"
+}