summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-08-25 14:50:09 +0200
committerPacho Ramos <pacho@gentoo.org>2016-08-25 14:53:59 +0200
commitb1dcecd9b4e1f25bae9bd8483a8c476520dab10c (patch)
tree67ece8185d36eb089fa03df7846a0624b6612645 /x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r2.ebuild
parentx11-plugins/gkrellm-volume: Drop old (diff)
downloadgentoo-b1dcecd9b4e1f25bae9bd8483a8c476520dab10c.tar.gz
gentoo-b1dcecd9b4e1f25bae9bd8483a8c476520dab10c.tar.bz2
gentoo-b1dcecd9b4e1f25bae9bd8483a8c476520dab10c.zip
x11-plugins/gkrellm-volume: Respect LDFLAGS, fix gcc calls and fix dependencies (#422543 by Michael Mair-Keimberger (iamnr3))
Package-Manager: portage-2.3.0
Diffstat (limited to 'x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r2.ebuild')
-rw-r--r--x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r2.ebuild25
1 files changed, 14 insertions, 11 deletions
diff --git a/x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r2.ebuild b/x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r2.ebuild
index a13bd83b9392..e9b82fd19019 100644
--- a/x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r2.ebuild
+++ b/x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r2.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="3"
-inherit gkrellm-plugin eutils
+EAPI=6
+inherit gkrellm-plugin toolchain-funcs
-IUSE="alsa"
DESCRIPTION="A mixer control plugin for gkrellm"
HOMEPAGE="http://gkrellm.luon.net/volume.php"
SRC_URI="http://gkrellm.luon.net/files/${P}.tar.gz"
@@ -13,20 +12,24 @@ SRC_URI="http://gkrellm.luon.net/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="2"
KEYWORDS="~alpha amd64 ~ppc ~sparc x86"
+IUSE="alsa"
DEPEND="alsa? ( media-libs/alsa-lib )"
+RDEPEND="${DEPEND}
+ app-admin/gkrellm[X]
+"
-S=${WORKDIR}/${PN}
+S="${WORKDIR}/${PN}"
-PLUGIN_SO=volume.so
+PLUGIN_SO="volume.so"
-src_prepare() {
- epatch "${FILESDIR}/${P}-reenable.patch"
- epatch "${FILESDIR}/${P}-Respect-LDFLAGS.patch"
-}
+PATCHES=(
+ "${FILESDIR}/${P}-reenable.patch"
+ "${FILESDIR}/${P}-makefile.patch"
+)
src_compile() {
local myconf=""
use alsa && myconf="${myconf} enable_alsa=1"
- make ${myconf} || die "make failed"
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" "${myconf}"
}