summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/gkrelltop
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/gkrelltop')
-rw-r--r--x11-plugins/gkrelltop/Manifest2
-rw-r--r--x11-plugins/gkrelltop/gkrelltop-2.2.11-r1.ebuild41
-rw-r--r--x11-plugins/gkrelltop/gkrelltop-2.2.11.ebuild34
-rw-r--r--x11-plugins/gkrelltop/gkrelltop-2.2.13.ebuild41
-rw-r--r--x11-plugins/gkrelltop/metadata.xml8
5 files changed, 126 insertions, 0 deletions
diff --git a/x11-plugins/gkrelltop/Manifest b/x11-plugins/gkrelltop/Manifest
new file mode 100644
index 000000000000..82a89d679a42
--- /dev/null
+++ b/x11-plugins/gkrelltop/Manifest
@@ -0,0 +1,2 @@
+DIST gkrelltop_2.2.11.orig.tar.gz 46280 SHA256 d80a76c129cc573e30f9edfe22e85f915d33ae2cae4245b66af692e5ee8ca61f SHA512 fc0e5b34d8ab48cbdca7f9efe5115352d72c638f809425839055ec6a2651c47cfe5ff8b1e5f88beef6760123875b5fdb4f7470ce3185e10e07f977a7e7e41a5a WHIRLPOOL 4a6d2eb4af48d4069b894ab520aef82523ef9d787fc88d21bde61fa9eec854f80cff1f77a81418e8cd501bca7387aec3906b88c747f9009b3095bacd018ae3ca
+DIST gkrelltop_2.2.13.orig.tar.gz 49023 SHA256 b2585c4186cc3805fcde73645a71d8eb3f798358caeb31cf3f598795e6ea42e6 SHA512 9479c5b860833671451b6fb8583e741b1ac755ed76b7e73dffd65d13d30d0b5da1916436901642f738e0d72f8c8696f4dea9c041a203e76d309f2782acf7024e WHIRLPOOL 893fa724cca39b2c07070ce4b979d47bc90cf9354cbabcca721f1386e60aeb30e08404566040bbc7404e949d325b4c7b74c1fe5f66e0b0c14884b2af8ac5cb5d
diff --git a/x11-plugins/gkrelltop/gkrelltop-2.2.11-r1.ebuild b/x11-plugins/gkrelltop/gkrelltop-2.2.11-r1.ebuild
new file mode 100644
index 000000000000..5ad0cba500e8
--- /dev/null
+++ b/x11-plugins/gkrelltop/gkrelltop-2.2.11-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="a GKrellM2 plugin which displays the top three processes"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}.orig.tar.gz"
+HOMEPAGE="http://sourceforge.net/projects/gkrelltop"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86"
+IUSE="X"
+
+PLUGIN_SERVER_SO=gkrelltopd.so
+PLUGIN_SO=gkrelltop.so
+
+S="${WORKDIR}/${P}.orig"
+
+RDEPEND="dev-libs/glib:2"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e "s:/usr/bin/gcc:$(tc-getCC) \$(CFLAGS):" \
+ -e 's/-shared/$(LDFLAGS) &/' \
+ Makefile || die
+}
+
+src_compile() {
+ use X || TARGET="server"
+ emake ${TARGET}
+}
+
+pkg_postinst() {
+ einfo "To enable the gkrelltopd server plugin, you must add the following"
+ einfo "line to /etc/gkrellmd.conf:"
+ einfo "\tplugin-enable gkrelltopd"
+}
diff --git a/x11-plugins/gkrelltop/gkrelltop-2.2.11.ebuild b/x11-plugins/gkrelltop/gkrelltop-2.2.11.ebuild
new file mode 100644
index 000000000000..3cc1df82e0ec
--- /dev/null
+++ b/x11-plugins/gkrelltop/gkrelltop-2.2.11.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit gkrellm-plugin
+
+DESCRIPTION="a GKrellM2 plugin which displays the top three processes"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}.orig.tar.gz"
+HOMEPAGE="http://sourceforge.net/projects/gkrelltop"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86"
+IUSE="X"
+
+PLUGIN_SERVER_SO=gkrelltopd.so
+PLUGIN_SO=gkrelltop.so
+
+S="${WORKDIR}/${P}.orig"
+
+RDEPEND="dev-libs/glib:2"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ use X || TARGET="server"
+ emake ${TARGET}
+}
+
+pkg_postinst() {
+ einfo "To enable the gkrelltopd server plugin, you must add the following"
+ einfo "line to /etc/gkrellmd.conf:"
+ einfo "\tplugin-enable gkrelltopd"
+}
diff --git a/x11-plugins/gkrelltop/gkrelltop-2.2.13.ebuild b/x11-plugins/gkrelltop/gkrelltop-2.2.13.ebuild
new file mode 100644
index 000000000000..b8cbde44476e
--- /dev/null
+++ b/x11-plugins/gkrelltop/gkrelltop-2.2.13.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="a GKrellM2 plugin which displays the top three processes"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}.orig.tar.gz"
+HOMEPAGE="http://sourceforge.net/projects/gkrelltop"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="X"
+
+PLUGIN_SERVER_SO=gkrelltopd.so
+PLUGIN_SO=gkrelltop.so
+
+S="${WORKDIR}/${P}.orig"
+
+RDEPEND="dev-libs/glib:2"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e "s:/usr/bin/gcc:$(tc-getCC) \$(CFLAGS):" \
+ -e 's/-shared/$(LDFLAGS) &/' \
+ Makefile || die
+}
+
+src_compile() {
+ use X || TARGET="server"
+ emake ${TARGET}
+}
+
+pkg_postinst() {
+ einfo "To enable the gkrelltopd server plugin, you must add the following"
+ einfo "line to /etc/gkrellmd.conf:"
+ einfo "\tplugin-enable gkrelltopd"
+}
diff --git a/x11-plugins/gkrelltop/metadata.xml b/x11-plugins/gkrelltop/metadata.xml
new file mode 100644
index 000000000000..60d4e1ded709
--- /dev/null
+++ b/x11-plugins/gkrelltop/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-dock</herd>
+ <upstream>
+ <remote-id type="sourceforge">gkrelltop</remote-id>
+ </upstream>
+</pkgmetadata>