summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/pidgin-latex
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/pidgin-latex')
-rw-r--r--x11-plugins/pidgin-latex/Manifest1
-rw-r--r--x11-plugins/pidgin-latex/metadata.xml12
-rw-r--r--x11-plugins/pidgin-latex/pidgin-latex-1.5.0.ebuild46
3 files changed, 59 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-latex/Manifest b/x11-plugins/pidgin-latex/Manifest
new file mode 100644
index 000000000000..d1961694b968
--- /dev/null
+++ b/x11-plugins/pidgin-latex/Manifest
@@ -0,0 +1 @@
+DIST pidgin-latex_1.5.0.tar.bz2 17585 SHA256 9c850aee90d7e59de834f83e09fa6e3e51b123f06e265ead70957608ada95441 SHA512 e9f81f948eb70880e027d3b83a058b509b860664f3c8fb39c95fa1ac5c0c843bf37f9b5abcf095ff30942dad7b55262c27494419d55af1c14898be4caddec912 WHIRLPOOL 56b1ee07fa4784cce078fce169775dcc946f040b87cb52fae2831edd9af2c66f93e75c0be03526a2fa9471ba3cea2c953910d136126f513c2e893d70ed214ed1
diff --git a/x11-plugins/pidgin-latex/metadata.xml b/x11-plugins/pidgin-latex/metadata.xml
new file mode 100644
index 000000000000..edb26b5a021b
--- /dev/null
+++ b/x11-plugins/pidgin-latex/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-im</herd>
+ <longdescription>
+A plugin for Pidgin which translates LaTeX code into images in your IM and Chat
+conversations.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">pidgin-latex</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-plugins/pidgin-latex/pidgin-latex-1.5.0.ebuild b/x11-plugins/pidgin-latex/pidgin-latex-1.5.0.ebuild
new file mode 100644
index 000000000000..f009b635ca2c
--- /dev/null
+++ b/x11-plugins/pidgin-latex/pidgin-latex-1.5.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit multilib toolchain-funcs
+
+MY_P=${PN}_${PV}
+
+DESCRIPTION="Pidgin plugin that renders latex formulae"
+HOMEPAGE="http://sourceforge.net/projects/pidgin-latex/"
+SRC_URI="mirror://sourceforge/pidgin-latex/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+COMMON_DEPEND="
+ net-im/pidgin[gtk]
+ x11-libs/gtk+:2"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/libtool
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ app-text/dvipng"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ sed -e "s:\(CC.*=\).*:\1 $(tc-getCC):" \
+ -e "/LIB_INSTALL_DIR/{s:/lib/pidgin:/$(get_libdir)/pidgin:;}" \
+ -i Makefile || die
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" install
+ dodoc README CHANGELOG TODO
+}
+
+pkg_postinst() {
+ elog 'Note, to see formulas either disable "Conversation Colors" plugin or'
+ elog 'switch off "ignore incoming format" option in plugin configuration.'
+ elog 'For details, take a look (and vote) at http://developer.pidgin.im/ticket/2772'
+}