summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2017-05-03 14:25:59 +0100
committerTony Vroon <chainsaw@gentoo.org>2017-05-03 14:25:59 +0100
commit0d7e05645328085a0e27d1dba3645dfae1c75941 (patch)
treeab5c9274abe246e8ffed585bed5c2fedb35838c1 /x11-plugins/purple-facebook/purple-facebook-20170330.ebuild
parentsys-apps/usbredir: ebuild maintenance (diff)
downloadgentoo-0d7e05645328085a0e27d1dba3645dfae1c75941.tar.gz
gentoo-0d7e05645328085a0e27d1dba3645dfae1c75941.tar.bz2
gentoo-0d7e05645328085a0e27d1dba3645dfae1c75941.zip
x11-plugins/purple-facebook: Version bump to 0.9.3-c9b74a765767 aka 20170330; ebuild by Vojtech Hrabal with some minor tweaks by me.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'x11-plugins/purple-facebook/purple-facebook-20170330.ebuild')
-rw-r--r--x11-plugins/purple-facebook/purple-facebook-20170330.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/x11-plugins/purple-facebook/purple-facebook-20170330.ebuild b/x11-plugins/purple-facebook/purple-facebook-20170330.ebuild
new file mode 100644
index 000000000000..5f438b2d6b0c
--- /dev/null
+++ b/x11-plugins/purple-facebook/purple-facebook-20170330.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils autotools
+
+MY_PV="0.9.3-c9b74a765767"
+S="${WORKDIR}/${PN}-${MY_PV}"
+DESCRIPTION="Facebook protocol plugin for libpurple"
+HOMEPAGE="https://github.com/dequis/purple-facebook"
+SRC_URI="https://github.com/dequis/${PN}/releases/download/v${MY_PV}/${PN}-${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-libs/json-glib
+ net-im/pidgin"
+DEPEND="${RDEPEND}"
+DOCS=( AUTHORS ChangeLog NEWS README VERSION )
+
+src_prepare() {
+ eautoreconf
+ default
+}