summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmMatrix
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmMatrix')
-rw-r--r--x11-plugins/wmMatrix/Manifest1
-rw-r--r--x11-plugins/wmMatrix/files/wmMatrix-0.2-makefile.patch34
-rw-r--r--x11-plugins/wmMatrix/metadata.xml9
-rw-r--r--x11-plugins/wmMatrix/wmMatrix-0.2-r1.ebuild39
4 files changed, 83 insertions, 0 deletions
diff --git a/x11-plugins/wmMatrix/Manifest b/x11-plugins/wmMatrix/Manifest
new file mode 100644
index 000000000000..249b49c97601
--- /dev/null
+++ b/x11-plugins/wmMatrix/Manifest
@@ -0,0 +1 @@
+DIST wmMatrix-0.2.tar.gz 225343 SHA256 ce7b18b1046985237388846332234fd5aaae7b6ba2476ba465e4e57208b75053
diff --git a/x11-plugins/wmMatrix/files/wmMatrix-0.2-makefile.patch b/x11-plugins/wmMatrix/files/wmMatrix-0.2-makefile.patch
new file mode 100644
index 000000000000..5225ad38f679
--- /dev/null
+++ b/x11-plugins/wmMatrix/files/wmMatrix-0.2-makefile.patch
@@ -0,0 +1,34 @@
+--- Makefile.orig 1999-08-16 18:01:58.000000000 +0200
++++ Makefile 2008-01-27 23:23:36.000000000 +0100
+@@ -1,8 +1,8 @@
+-CC = gcc
+-CFLAGS = -O2 -Wall
+-INCDIR = -I/usr/X11R6/include/X11 -I/usr/X11R6/include
+-DESTDIR= /usr/X11R6
+-LIBDIR = -L/usr/X11R6/lib
++CC ?= gcc
++CFLAGS += -Wall
++INCDIR = -I/usr/include/X11 -I/usr/include
++PREFIX ?= /usr
++LIBDIR ?= /usr/lib
+
+ # for Linux
+ LIBS = -lXpm -lX11 -lXext
+@@ -24,7 +24,7 @@
+
+ wmMatrix.o: wmMatrix_master.xpm wmMatrix_mask.xbm
+ wmMatrix: $(OBJS)
+- $(CC) $(COPTS) $(SYSTEM) -o wmMatrix $^ $(INCDIR) $(LIBDIR) $(LIBS)
++ $(CC) $(COPTS) $(SYSTEM) -o wmMatrix $^ $(INCDIR) -L$(LIBDIR) $(LDFLAGS) $(LIBS)
+
+
+ clean:
+@@ -34,5 +34,6 @@
+ rm -f wmMatrix
+
+ install:: wmMatrix
+- install -c -s -m 0755 wmMatrix $(DESTDIR)/bin
++ install -d $(DESTDIR)$(PREFIX)/bin
++ install -m 0755 wmMatrix $(DESTDIR)$(PREFIX)/bin
+
+
diff --git a/x11-plugins/wmMatrix/metadata.xml b/x11-plugins/wmMatrix/metadata.xml
new file mode 100644
index 000000000000..4c1c7b70d395
--- /dev/null
+++ b/x11-plugins/wmMatrix/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-dock</herd>
+ <longdescription>
+ wmMatrix is an early beta version of a cpu monitor built around the display
+ from the movie"The Matrix".
+ </longdescription>
+</pkgmetadata>
diff --git a/x11-plugins/wmMatrix/wmMatrix-0.2-r1.ebuild b/x11-plugins/wmMatrix/wmMatrix-0.2-r1.ebuild
new file mode 100644
index 000000000000..99e004ace3fa
--- /dev/null
+++ b/x11-plugins/wmMatrix/wmMatrix-0.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="WMaker DockApp: Slightly modified version of Jamie Zawinski's xmatrix screenhack"
+SRC_URI="http://dockapps.windowmaker.org/download.php/id/17/${P}.tar.gz"
+HOMEPAGE="http://dockapps.windowmaker.org/file.php/id/10"
+
+CDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${CDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto"
+RDEPEND="${CDEPEND}
+ x11-misc/xscreensaver"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ # this version is distributed with compiled binaries!
+ make clean
+ emake CC="$(tc-getCC)" LIBDIR="/usr/$(get_libdir)" || die "compile failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "install failed"
+}