summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-09-18 19:02:48 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2023-09-19 22:37:31 +0200
commit8d4f75a28178b1ad5c7703cf02c5baff2aabd7a4 (patch)
treee617b0ba42613e459dff1422c1937e0b1357973c /x11-plugins/wmSpaceWeather
parentx11-plugins/wmpop3: EAPI8 bump (diff)
downloadgentoo-8d4f75a28178b1ad5c7703cf02c5baff2aabd7a4.tar.gz
gentoo-8d4f75a28178b1ad5c7703cf02c5baff2aabd7a4.tar.bz2
gentoo-8d4f75a28178b1ad5c7703cf02c5baff2aabd7a4.zip
x11-plugins/wmSpaceWeather: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins/wmSpaceWeather')
-rw-r--r--x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19-r2.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19-r2.ebuild b/x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19-r2.ebuild
new file mode 100644
index 000000000000..79419409b173
--- /dev/null
+++ b/x11-plugins/wmSpaceWeather/wmSpaceWeather-1.04_p19-r2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN="wmspaceweather"
+MY_PV_ORIG="${PV/_p*}"
+MY_PV_PATCH="${PV/_p/-}"
+MY_P_ORIG="${MY_PN}_${MY_PV_ORIG}.orig"
+MY_P_PATCH="${MY_PN}_${MY_PV_PATCH}.diff"
+
+DESCRIPTION="Dockapp showing weather at geosynchronous orbit"
+HOMEPAGE="https://www.dockapps.net/wmspaceweather"
+SRC_URI="mirror://debian/pool/main/w/${MY_PN}/${MY_P_ORIG}.tar.gz
+ mirror://debian/pool/main/w/${MY_PN}/${MY_P_PATCH}.gz"
+S="${WORKDIR}/${MY_P_ORIG/_/-}/${PN}"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+
+DOCS=( ../{BUGS,CHANGES,HINTS,README} )
+
+CDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${CDEPEND}
+ x11-base/xorg-proto"
+RDEPEND="${CDEPEND}
+ net-misc/curl
+ dev-lang/perl"
+
+src_prepare() {
+ default
+
+ cd .. || die
+
+ eapply "${WORKDIR}"/${MY_P_PATCH}
+ eapply "${FILESDIR}"/${P}-gcc-10.patch
+
+ # need to apply patches from Debian first, do NOT change the order
+ cd "${S}" || die
+ eapply -p2 ../debian/patches/*.dpatch
+ eapply "${FILESDIR}"/${P}-gentoo.patch
+ eapply "${FILESDIR}"/${P}-getkp.patch
+}
+
+src_compile() {
+ emake clean
+ emake CC="$(tc-getCC)" LIBDIR="/usr/$(get_libdir)"
+}
+
+pkg_postinst() {
+ elog "You need to emerge www-client/firefox or www-client/firefox-bin"
+ elog "to use the -url functionality - see man ${PN} for more info."
+ elog
+ elog "This version uses curl instead of wget. You may edit /usr/share/wmspaceweather/GetKp"
+ elog "if you don't like it."
+}