summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2021-01-03 00:29:35 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2021-01-03 00:32:20 +0100
commit2d0894ebcc2735be955d70f14f02d37d93043603 (patch)
tree329339f3b5fe96703ec5d8de2cf86cf21b2880df /x11-plugins/wmbiff
parentx11-plugins/wmweather+: do not call ar directly (diff)
downloadgentoo-2d0894ebcc2735be955d70f14f02d37d93043603.tar.gz
gentoo-2d0894ebcc2735be955d70f14f02d37d93043603.tar.bz2
gentoo-2d0894ebcc2735be955d70f14f02d37d93043603.zip
x11-plugins/wmbiff: do not call ar directly
Closes: https://bugs.gentoo.org/726284 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins/wmbiff')
-rw-r--r--x11-plugins/wmbiff/files/wmbiff-0.4.36-ar.patch11
-rw-r--r--x11-plugins/wmbiff/wmbiff-0.4.36.ebuild9
2 files changed, 19 insertions, 1 deletions
diff --git a/x11-plugins/wmbiff/files/wmbiff-0.4.36-ar.patch b/x11-plugins/wmbiff/files/wmbiff-0.4.36-ar.patch
new file mode 100644
index 000000000000..da1f194dd4cf
--- /dev/null
+++ b/x11-plugins/wmbiff/files/wmbiff-0.4.36-ar.patch
@@ -0,0 +1,11 @@
+diff -Naur wmbiff-0.4.36.orig/configure.ac wmbiff-0.4.36/configure.ac
+--- wmbiff-0.4.36.orig/configure.ac 2020-04-17 19:30:26.000000000 +0200
++++ wmbiff-0.4.36/configure.ac 2021-01-03 00:27:57.522698494 +0100
+@@ -13,6 +13,7 @@
+ AH_TEMPLATE([VERSION], [wmbiff's release version])
+ AC_SUBST(VERSION)
+
++AM_PROG_AR
+ AC_PROG_INSTALL
+ AC_PROG_CC
+ AC_PROG_RANLIB
diff --git a/x11-plugins/wmbiff/wmbiff-0.4.36.ebuild b/x11-plugins/wmbiff/wmbiff-0.4.36.ebuild
index 9bc7ddb28d8b..7f44590d0960 100644
--- a/x11-plugins/wmbiff/wmbiff-0.4.36.ebuild
+++ b/x11-plugins/wmbiff/wmbiff-0.4.36.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit autotools
DESCRIPTION="WMBiff is a dock applet for WindowMaker which can monitor up to 5 mailboxes"
HOMEPAGE="https://www.dockapps.net/wmbiff"
@@ -26,8 +27,14 @@ BDEPEND="virtual/pkgconfig"
DOCS="ChangeLog FAQ NEWS README TODO wmbiff/sample.wmbiffrc"
PATCHES=(
"${FILESDIR}"/${PN}-0.4.27-invalid-strncpy.patch
+ "${FILESDIR}"/${P}-ar.patch
)
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
econf $(use_enable crypt crypto)
}