summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmjsql
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmjsql')
-rw-r--r--x11-plugins/wmjsql/Manifest1
-rw-r--r--x11-plugins/wmjsql/files/wmjsql.desktop8
-rw-r--r--x11-plugins/wmjsql/metadata.xml5
-rw-r--r--x11-plugins/wmjsql/wmjsql-0.5.ebuild50
4 files changed, 64 insertions, 0 deletions
diff --git a/x11-plugins/wmjsql/Manifest b/x11-plugins/wmjsql/Manifest
new file mode 100644
index 000000000000..47e516276877
--- /dev/null
+++ b/x11-plugins/wmjsql/Manifest
@@ -0,0 +1 @@
+DIST wmjsql-0.5.tar.gz 62739 SHA256 5c7ac2a3ff789ce85a8dbdf0b7591d9abf05b906c05700bb2760e1ad75aeccd0
diff --git a/x11-plugins/wmjsql/files/wmjsql.desktop b/x11-plugins/wmjsql/files/wmjsql.desktop
new file mode 100644
index 000000000000..78d35df8f9da
--- /dev/null
+++ b/x11-plugins/wmjsql/files/wmjsql.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=WmJSQL
+Comment=MySQL Monitor
+Comment[pl]=Monitor MySQLa
+Exec=wmjsql
+Type=Application
+Terminal=false
+Categories=Development;Database;
diff --git a/x11-plugins/wmjsql/metadata.xml b/x11-plugins/wmjsql/metadata.xml
new file mode 100644
index 000000000000..b1a9efc4f2f0
--- /dev/null
+++ b/x11-plugins/wmjsql/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+</pkgmetadata>
diff --git a/x11-plugins/wmjsql/wmjsql-0.5.ebuild b/x11-plugins/wmjsql/wmjsql-0.5.ebuild
new file mode 100644
index 000000000000..2b3a5ce1a1a4
--- /dev/null
+++ b/x11-plugins/wmjsql/wmjsql-0.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit eutils
+
+MY_P="${PN}"
+
+DESCRIPTION="MySQL monitor dockapp"
+HOMEPAGE="http://dockapps.windowmaker.org/file.php/id/42"
+SRC_URI="http://dockapps.windowmaker.org/download.php/id/73/${P}.tar.gz"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto
+ >=virtual/mysql-4.0"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="ppc sparc x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed -i "s/make/\$(MAKE)/g" src/Makefile || die
+}
+
+src_compile() {
+ cd "${S}"/src
+ emake clean || die
+ emake CFLAGS="${CFLAGS}" SYSTEM="${LDFLAGS}" || die
+}
+
+src_install() {
+ cd "${S}"/src
+ dobin wmjsql || die
+ newdoc conf sample.wmjsql
+
+ cd "${S}"
+ dodoc CREDITS README TODO
+
+ domenu "${FILESDIR}"/${PN}.desktop
+}