summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2018-01-06 01:51:28 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-01-06 01:51:28 +0300
commitf2640861a990c5169359252371b5011b9618fd80 (patch)
treeea9ef12a367247d0b9d7682638398214ad051342 /x11-plugins/wmmsg
parentx11-plugins/wmmldonkey: remove last rited package (bug #639914) (diff)
downloadgentoo-f2640861a990c5169359252371b5011b9618fd80.tar.gz
gentoo-f2640861a990c5169359252371b5011b9618fd80.tar.bz2
gentoo-f2640861a990c5169359252371b5011b9618fd80.zip
x11-plugins/wmmsg: remove last rited package (bug #639914)
Diffstat (limited to 'x11-plugins/wmmsg')
-rw-r--r--x11-plugins/wmmsg/Manifest1
-rw-r--r--x11-plugins/wmmsg/files/wmmsg-1.0.1-alt-desktop.patch11
-rw-r--r--x11-plugins/wmmsg/files/wmmsg-1.0.1-list.patch132
-rw-r--r--x11-plugins/wmmsg/files/wmmsg-1.0.1-use_gtk2.patch44
-rw-r--r--x11-plugins/wmmsg/metadata.xml15
-rw-r--r--x11-plugins/wmmsg/wmmsg-1.0.1-r2.ebuild36
6 files changed, 0 insertions, 239 deletions
diff --git a/x11-plugins/wmmsg/Manifest b/x11-plugins/wmmsg/Manifest
deleted file mode 100644
index 122b489a2ab0..000000000000
--- a/x11-plugins/wmmsg/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST wmmsg-1.0.1.tar.gz 322551 BLAKE2B 585559f331549ec222984f5b377f61d10576b740a1080ae30466dab5bf0ccf97a23c178e69743c202407d40c0720e47fe756c093e8fd6b7d2d2b302a5a69f2ea SHA512 6897a6cb48d88536bf9bde4ae824ddeba7953618666aca24202d9d21865d63c9d0d28a306b8f249da8052715be706a02de12c90c14718b1b3bd41d3803dd6abe
diff --git a/x11-plugins/wmmsg/files/wmmsg-1.0.1-alt-desktop.patch b/x11-plugins/wmmsg/files/wmmsg-1.0.1-alt-desktop.patch
deleted file mode 100644
index 5a7135d7cc30..000000000000
--- a/x11-plugins/wmmsg/files/wmmsg-1.0.1-alt-desktop.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- wmmsg-1.0.1/src/wmmsg/wmmsg.c.vns 2003-02-04 06:40:12 +0300
-+++ wmmsg-1.0.1/src/wmmsg/wmmsg.c 2006-03-26 21:42:45 +0400
-@@ -144,7 +144,7 @@
- WMMSG_MASK_WIDTH, WMMSG_MASK_HEIGHT);
- openXwindow (argc, argv, wmmsg_xpm, global_wmmsg_mask_bits,
- WMMSG_MASK_WIDTH, WMMSG_MASK_HEIGHT);
-- global_win_workspace = XInternAtom(display, "_WIN_WORKSPACE", 0);
-+ global_win_workspace = XInternAtom(display, "_NET_CURRENT_DESKTOP", 0);
-
- //add clickable regions
- for(i = 0; i < MESSAGES_PER_SCREEN; i++)
diff --git a/x11-plugins/wmmsg/files/wmmsg-1.0.1-list.patch b/x11-plugins/wmmsg/files/wmmsg-1.0.1-list.patch
deleted file mode 100644
index 76d2e26fbc61..000000000000
--- a/x11-plugins/wmmsg/files/wmmsg-1.0.1-list.patch
+++ /dev/null
@@ -1,132 +0,0 @@
-diff -Naur wmmsg-1.0.1/src/wmgeneral.orig/list.c wmmsg-1.0.1/src/wmgeneral/list.c
---- wmmsg-1.0.1/src/wmgeneral.orig/list.c 2016-01-04 13:03:23.206828813 +0100
-+++ wmmsg-1.0.1/src/wmgeneral/list.c 2016-01-04 13:03:32.358832037 +0100
-@@ -38,7 +38,7 @@
-
- /* Return a cons cell produced from (head . tail) */
-
--INLINE LinkedList * list_cons (void *head, LinkedList * tail)
-+LinkedList * list_cons (void *head, LinkedList * tail)
- {
- LinkedList *cell;
-
-@@ -50,7 +50,7 @@
-
- /* Return the length of a list, list_length(NULL) returns zero */
-
--INLINE int list_length (LinkedList * list)
-+int list_length (LinkedList * list)
- {
- int i = 0;
- while (list)
-@@ -64,7 +64,7 @@
- /* Return the Nth element of LIST, where N count from zero. If N
- larger than the list length, NULL is returned */
-
--INLINE void * list_nth (int index, LinkedList * list)
-+void * list_nth (int index, LinkedList * list)
- {
- while (index-- != 0)
- {
-@@ -78,7 +78,7 @@
-
- /* Remove the element at the head by replacing it by its successor */
-
--INLINE void list_remove_head (LinkedList ** list)
-+void list_remove_head (LinkedList ** list)
- {
- if (!*list)
- return;
-@@ -98,19 +98,7 @@
-
-
- /* Remove the element with `car' set to ELEMENT */
--/*
-- INLINE void
-- list_remove_elem(LinkedList** list, void* elem)
-- {
-- while (*list)
-- {
-- if ((*list)->head == elem)
-- list_remove_head(list);
-- *list = (*list ? (*list)->tail : NULL);
-- }
-- } */
--
--INLINE LinkedList * list_remove_elem (LinkedList * list, void *elem)
-+LinkedList * list_remove_elem (LinkedList * list, void *elem)
- {
- LinkedList *tmp;
-
-@@ -131,7 +119,7 @@
-
- /* Return element that has ELEM as car */
-
--INLINE LinkedList * list_find (LinkedList * list, void *elem)
-+LinkedList * list_find (LinkedList * list, void *elem)
- {
- while (list)
- {
-@@ -144,7 +132,7 @@
-
- /* Free list (backwards recursive) */
-
--INLINE void list_free (LinkedList * list)
-+void list_free (LinkedList * list)
- {
- if (list)
- {
-@@ -155,7 +143,7 @@
-
- /* Map FUNCTION over all elements in LIST */
-
--INLINE void list_mapcar (LinkedList * list, void (*function) (void *))
-+void list_mapcar (LinkedList * list, void (*function) (void *))
- {
- while (list)
- {
-diff -Naur wmmsg-1.0.1/src/wmgeneral.orig/list.h wmmsg-1.0.1/src/wmgeneral/list.h
---- wmmsg-1.0.1/src/wmgeneral.orig/list.h 2016-01-04 13:03:23.206828813 +0100
-+++ wmmsg-1.0.1/src/wmgeneral/list.h 2016-01-04 13:03:46.741837100 +0100
-@@ -29,12 +29,6 @@
- #ifndef __LIST_H_
- #define __LIST_H_
-
--#if defined(__GNUC__) && !defined(__STRICT_ANSI__)
--#define INLINE inline
--#else
--#define INLINE
--#endif
--
- typedef struct LinkedList
- {
- void *head;
-@@ -42,20 +36,20 @@
- }
- LinkedList;
-
--INLINE LinkedList *list_cons (void *head, LinkedList * tail);
-+LinkedList *list_cons (void *head, LinkedList * tail);
-
--INLINE int list_length (LinkedList * list);
-+int list_length (LinkedList * list);
-
--INLINE void *list_nth (int index, LinkedList * list);
-+void *list_nth (int index, LinkedList * list);
-
--INLINE void list_remove_head (LinkedList ** list);
-+void list_remove_head (LinkedList ** list);
-
--INLINE LinkedList *list_remove_elem (LinkedList * list, void *elem);
-+LinkedList *list_remove_elem (LinkedList * list, void *elem);
-
--INLINE void list_mapcar (LinkedList * list, void (*function) (void *));
-+void list_mapcar (LinkedList * list, void (*function) (void *));
-
--INLINE LinkedList *list_find (LinkedList * list, void *elem);
-+LinkedList *list_find (LinkedList * list, void *elem);
-
--INLINE void list_free (LinkedList * list);
-+void list_free (LinkedList * list);
-
- #endif
diff --git a/x11-plugins/wmmsg/files/wmmsg-1.0.1-use_gtk2.patch b/x11-plugins/wmmsg/files/wmmsg-1.0.1-use_gtk2.patch
deleted file mode 100644
index 6bdc05e36237..000000000000
--- a/x11-plugins/wmmsg/files/wmmsg-1.0.1-use_gtk2.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff -ur wmmsg-1.0.1.orig/configure.in wmmsg-1.0.1/configure.in
---- wmmsg-1.0.1.orig/configure.in 2004-10-04 19:57:13.000000000 +0300
-+++ wmmsg-1.0.1/configure.in 2008-03-12 17:45:29.000000000 +0200
-@@ -17,11 +17,6 @@
- AM_MAINTAINER_MODE
-
- # get options
--AC_ARG_WITH(gtk,
-- [ --with-gtk=DIR use gtk in <DIR>],
-- [CFLAGS="$CFLAGS -I$withval/include"
-- LIBS="-L$withval/lib $LIBS"])
--
- AC_ARG_WITH(imlib2,
- [ --with-imlib2=DIR use imlib2 in <DIR>],
- [CFLAGS="$CFLAGS -I$withval/include"
-@@ -32,10 +27,9 @@
- AC_CHECK_LIB([m], [sin])
-
- # Check for glib/gtk stuff
--AM_PATH_GLIB(1.2.2,,AC_MSG_ERROR([*** GLIB >= 1.2.2 not installed - please insta
--ll first ***]))
--AM_PATH_GTK(1.2.2,,AC_MSG_ERROR([*** GTK+ >= 1.2.2 not installed - please instal
--l first ***]),gthread)
-+PKG_CHECK_MODULES(GTK, [gtk+-2.0 >= 2.0.0])
-+AC_SUBST(GTK_CFLAGS)
-+AC_SUBST(GTK_LIBS)
-
- # check for Imlib2
- AC_PATH_GENERIC(imlib2, 1.0.0, [
-diff -ur wmmsg-1.0.1.orig/Makefile.am wmmsg-1.0.1/Makefile.am
---- wmmsg-1.0.1.orig/Makefile.am 2003-03-26 09:08:21.000000000 +0200
-+++ wmmsg-1.0.1/Makefile.am 2008-03-12 17:42:48.000000000 +0200
-@@ -3,8 +3,9 @@
- bin_PROGRAMS = wmmsg wmmsg_notify
- wmmsg_SOURCES = src/wmmsg/wmconfig.c src/wmmsg/wmmsg.c src/wmmsg/getopt.c src/wmgeneral/wmgeneral.c src/wmgeneral/misc.c src/wmgeneral/list.c
- wmmsg_notify_SOURCES = src/wmmsg/wmmsg_notify.c src/wmmsg/getopt.c
--INCLUDES = -I/usr/X11R6/include -I$(prefix)/include -I$(includedir) -I. `glib-config --cflags` `gtk-config --cflags` `imlib2-config --cflags`
--AM_LDFLAGS = -lX11 -lXext -lXpm -L/usr/X11R6/lib -L/usr/lib -L/usr/local/lib `glib-config --libs` `gtk-config --libs` `imlib2-config --libs`
-+INCLUDES = -I$(prefix)/include -I$(includedir) -I. `pkg-config --cflags gtk+-2.0` `imlib2-config --cflags`
-+wmmsg_LDADD = -lX11 -lXext -lXpm -L/usr/lib -L/usr/local/lib $(GTK_LIBS) $(IMLIB_LIBS)
-+wmmsg_notify_LDADD = $(wmmsg_LDADD)
-
- man1_MANS = man/wmmsg.1 man/wmmsg_notify.1
- man_MANS =
diff --git a/x11-plugins/wmmsg/metadata.xml b/x11-plugins/wmmsg/metadata.xml
deleted file mode 100644
index 6498eab3ceba..000000000000
--- a/x11-plugins/wmmsg/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="person">
- <email>voyageur@gentoo.org</email>
- <name>Bernard Cafarelli</name>
-</maintainer>
-
-<longdescription>
-wmmsg is a dockapp that informs you of new events, such as incoming chat
-messages, by displaying related icons and arrival times. A notification
-program, wmmsg_notify, is included to send events to the dockapp. This can be
-called from messaging clients, or any other useful location.
-</longdescription>
-</pkgmetadata>
diff --git a/x11-plugins/wmmsg/wmmsg-1.0.1-r2.ebuild b/x11-plugins/wmmsg/wmmsg-1.0.1-r2.ebuild
deleted file mode 100644
index f08f03409638..000000000000
--- a/x11-plugins/wmmsg/wmmsg-1.0.1-r2.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit autotools
-
-DESCRIPTION="universal visual notification dockapp"
-HOMEPAGE="http://swapspace.net/~matt/wmmsg"
-SRC_URI="http://swapspace.net/~matt/wmmsg/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ~sparc x86"
-IUSE=""
-
-RDEPEND="x11-libs/gtk+:2
- media-libs/imlib2[X]
- x11-libs/libXpm
- x11-libs/libXext
- x11-libs/libX11"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- x11-libs/libXt"
-
-DOCS=( AUTHORS ChangeLog README wmmsgrc )
-PATCHES=(
- "${FILESDIR}"/${P}-use_gtk2.patch
- "${FILESDIR}"/${P}-alt-desktop.patch
- "${FILESDIR}"/${P}-list.patch
- )
-
-src_prepare() {
- default
-
- eautoreconf
-}