summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-01-29 18:49:53 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2020-01-29 19:26:59 +0100
commit5749ea57c106309a71d79ad589e1e964b0953a07 (patch)
treee3a632bb3518058aca25f19ba2422b8ae8267c6e /x11-plugins/wmpop3lb
parentx11-plugins/wmxres: fix build with -fno-common (diff)
downloadgentoo-5749ea57c106309a71d79ad589e1e964b0953a07.tar.gz
gentoo-5749ea57c106309a71d79ad589e1e964b0953a07.tar.bz2
gentoo-5749ea57c106309a71d79ad589e1e964b0953a07.zip
x11-plugins/wmpop3lb: fix build with -fno-common
Closes: https://bugs.gentoo.org/706550 Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins/wmpop3lb')
-rw-r--r--x11-plugins/wmpop3lb/files/wmpop3lb-2.4.2-gcc-10.patch21
-rw-r--r--x11-plugins/wmpop3lb/wmpop3lb-2.4.2-r3.ebuild5
2 files changed, 24 insertions, 2 deletions
diff --git a/x11-plugins/wmpop3lb/files/wmpop3lb-2.4.2-gcc-10.patch b/x11-plugins/wmpop3lb/files/wmpop3lb-2.4.2-gcc-10.patch
new file mode 100644
index 000000000000..5beb41552562
--- /dev/null
+++ b/x11-plugins/wmpop3lb/files/wmpop3lb-2.4.2-gcc-10.patch
@@ -0,0 +1,21 @@
+--- a/wmgeneral/wmgeneral.c
++++ b/wmgeneral/wmgeneral.c
+@@ -45,6 +45,7 @@ Window iconwin, win;
+ GC NormalGC;
+ XpmIcon wmgen;
+ Pixmap pixmask;
++Display *display;
+
+ /*****************/
+ /* Mouse Regions */
+--- a/wmgeneral/wmgeneral.h
++++ b/wmgeneral/wmgeneral.h
+@@ -21,7 +21,7 @@ typedef struct {
+ /* Global variable */
+ /*******************/
+
+-Display *display;
++extern Display *display;
+
+ /***********************/
+ /* Function Prototypes */
diff --git a/x11-plugins/wmpop3lb/wmpop3lb-2.4.2-r3.ebuild b/x11-plugins/wmpop3lb/wmpop3lb-2.4.2-r3.ebuild
index 99e7ab4db582..05a951236c01 100644
--- a/x11-plugins/wmpop3lb/wmpop3lb-2.4.2-r3.ebuild
+++ b/x11-plugins/wmpop3lb/wmpop3lb-2.4.2-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,7 +20,8 @@ DEPEND="${RDEPEND}"
S=${WORKDIR}/${P/-}
PATCHES=( "${FILESDIR}"/${P}-fix-RECV-and-try-STAT-if-LAST-wont-work.patch
- "${FILESDIR}"/${P}-list.patch )
+ "${FILESDIR}"/${P}-list.patch
+ "${FILESDIR}"/${P}-gcc-10.patch )
src_prepare() {
#Honour Gentoo CFLAGS